Getting error when trying to load a file

praba71
Frequent Contributor

Getting error when trying to load a file

Hi

I am trying to load a data file into my module, using the navigation Action<Import Data Source but getting 

'Unmatched Delimiter character '. Please see the screenshot of the error and the datafile. We want to keep double quote (") as the text delimiter for our data import. 

can you throw some light on what is the issue here?

 

Thanks

Prabakaran

 

6 REPLIES 6
JaredDolich
Master Anaplanner/Community Boss

Re: Getting error when trying to load a file

@praba71 

You're very close there. See where it says "other" for the delimiter? You have it set as a comma. Change that to a double quote by checking the "other" Boolean and setting the delimiter to double quote. The text double quote is used to identify text columns so it doesn't get confused with what is inside the double quotes. 


Jared Dolich
praba71
Frequent Contributor

Re: Getting error when trying to load a file

Hi @JaredDolich thanks for the response.

Just to make it clear, I am using .csv file for the data import, hence I use comma as the column separator.

I do have single quote in the value of one of the text column, hence using double quote as the text delimiter.

 

Thanks

Regards

Prabakaran

 

JaredDolich
Master Anaplanner/Community Boss

Re: Getting error when trying to load a file

@praba71 

Can you check your descriptions and see if any of them have a double quote? Wondering if that might be the issue. I don't see anything wrong with the file that you shared but I can't see the whole description.


Jared Dolich
praba71
Frequent Contributor

Re: Getting error when trying to load a file

Hi @JaredDolich 

Please see the data from my file below. The third column ' Description' has double quotes in it, but to distinguish them we add \ before the double quote. If that will not solve the issue, then any suggestion on how to workaround this?

 

Sequence,Item,Description,Org, Transaction Type,Source,Date,Transaction Quantity,Current Month,Current Quarter,Current Year,Report Timestamp
1,HDD0340,"WD 600GB SAS, 10K, 2.5\" (WD6002BKTG)",GQ1,Account alias issue,DC-CONSUMPTION,09/20/2020,1,Feb 21,Q1 FY21,FY21,02/22/2021 23:54
2,HDD0340,"WD 600GB SAS, 10K, 2.5\" (WD6002BKTG)",NEX,WIP Issue,318565,01/13/2021,8,Feb 21,Q1 FY21,FY21,02/22/2021 23:54
3,HDD0340,"WD 600GB SAS, 10K, 2.5\" (WD6002BKTG)",GQ1,Account alias issue,DC-CONSUMPTION,12/06/2020,1,Feb 21,Q1 FY21,FY21,02/22/2021 23:54

 

Thanks 

Regards

Prabakaran

JaredDolich
Master Anaplanner/Community Boss

Re: Getting error when trying to load a file

@praba71 Looks like you  need a comma after the 2.5 since the comma is the delimiter.


Jared Dolich
alexpavel
Certified Master Anaplanner

Re: Getting error when trying to load a file

@praba71  The error is coming from the description field: The Description contains double quotes characters... If you used the "Text Delimeter" property as double quotes character, then in the file you need to have 2 double quotes... and you have the \"  instead: ("WD 600GB SAS, 10K, 2.5\" (WD6002BKTG)"

 

The only way to solve this is to replace \"  with ""  in your file. 

 

"WD 600GB SAS, 10K, 2.5\" (WD6002BKTG)"  needs to be replaced with "WD 600GB SAS, 10K, 2.5"" (WD6002BKTG)"

 

alexpavel_0-1614090229323.png

 

Anaplan does not recognize as escape character the backslash (\) but...instead.. the double quotes character needs to be doubled in the file ("") 

 

Hope it helps...