Import: Mapping Issue with Tab Separators

MaoNinomiya
Contributor

Import: Mapping Issue with Tab Separators

Hi all,

 

When I tried to upload .csv file with Tab separator, I cannot see any mapping with setting (Please refer to the file called "Separtors=Tab.PNG") and import went to be failed.

With Column separator, however, I could see what items were mapped (Refer to the the file "Separators=Column.png).

 

The difference between those files are only the separator.

Could anyone can tell me why these difference is occurred and how to solve the issue with Tab separator?

 

Thanks

 

6 REPLIES 6
nathan_rudman
Community Boss

what do you call column separator ?

 

Open your file with Notepad++ and display the special characters, you'll see if you have an issue in there


Nathan Rudman, Anaplan Model Builder
MaoNinomiya
Contributor

@nathan_rudman 

 

Thanks for your quick response.

 

>Open your file with Notepad++ and display the special characters, you'll see if you have an issue in there

I'll check.

Are you saying that tab separator won't work if there is any special characters in column (or maybe rows)?

 

Mao Ninomiya

 

nathan_rudman
Community Boss

no, but you might have a tab somewhere in the data that pushes all the mapping one or two columns, although that wouldn't be for all lines.

I don't understand what you mean by separator = column so I'm asking you to check what exactly you have in your file as a separator. It seems it is not tab.

Nathan Rudman, Anaplan Model Builder
MaoNinomiya
Contributor

Sorry for making you misunderstand. separator = column means “Separator=Commma”.

 

 

abhay.kanik
Super Contributor

@MaoNinomiya I think you are trying to import a tab delimited file with configuration of comma separated file.

I Suggest you to check this config once.

 
 
 

Screenshot 2020-07-13 at 2.52.20 PM.png

 

 

MaoNinomiya
Contributor

By fixing text delimiter setting in File Option, the file was imported successfully.

Thanks to @abhay.kanik  and @nathan_rudman  for helping me solve the issue.