L1MB 9.2.5

Davidm96
New Contributor

L1MB 9.2.5

trying to put in the formula's but keep getting an error message. Tried looking for answers but nothing seems to be working 

 

 

 

14 REPLIES 14
JaredDolich
Moderator

Re: L1MB 9.2.5

@Davidm96 

Your syntax is correct, so the error you are getting is probably related to the way you spelled the line item in REV04. Check the spelling of Unit Price %. You may have spelled it Unit Price% without the space. 

TBH, the best way to create the formula is to use the editor bar and navigate to the line item and use the mouse instead of typing it in. This way if there are any special characters or the spelling is a little different, Anaplan will get it right. If the spelling is the same, then try looking at SYS04 and SYS06 spelling.

Give it another try. Your almost there.


Jared Dolich
Davidm96
New Contributor

Re: L1MB 9.2.5

Thank you for the reply. still stuck on this issue as the spelling is correct for everything and still seeming to get that issue for an error 

JaredDolich
Moderator

Re: L1MB 9.2.5

@Davidm96 

No problem. We'll find the issue. Next, let's make sure your system module line items are formatted correctly. Can you validate that Country and Product Family in your system modules are formatted as Lists? Also, attach a screenshot of your system module blueprint for each of those system modules. Lastly, make sure you are using the mouse to enter the line items rather than typing them in.


Jared Dolich
Akhtar.shahbaz
Community Boss

Re: L1MB 9.2.5

@Davidm96 ,

 

As @JaredDolich  mentioned your formula looks correct but what I have noticed in the screenshot is you have Subsidairy View in the line item, so make sure your REV04 & REV05 should be by year.

Goto blueprint -> Time Scale -> Change to year

 

Screenshot_286.png

 

Thanks

Akhtar

Davidm96
New Contributor

Re: L1MB 9.2.5

I have both set to year instead of month and checked all my spelling and formatting 

Davidm96
New Contributor

Re: L1MB 9.2.5

here's also the blueprint of each module 

JaredDolich
Moderator

Re: L1MB 9.2.5

@Davidm96 

Bingo! @Akhtar.shahbaz called it. You need to resolve the subsidiary views. to do this make sure your line items match your module in the "applies to" AND the "calendar". Like so,

 

JaredDolich_0-1639354340089.png

 

JaredDolich_1-1639354419209.png

 


Jared Dolich
Davidm96
New Contributor

Re: L1MB 9.2.5

thank you again for replying so much that worked! the only other issue i have with lesson is the % forwarding over. 

JaredDolich
Moderator

Re: L1MB 9.2.5

@Davidm96 

Looks like it's working. Take the context selector down to a product and location. For example, New York and Nutzo Bar. There is where you should see the correct percentage. The reason why you see a large number there at US and Chocolates is because you are adding up the percentages. If you don't want to see those at that level, you can either turn off the summaries, or set the summary to Average.


Jared Dolich