Level 1 Model Building Exam - Model Building Activity 5

HarshaR
Occasional Contributor

Level 1 Model Building Exam - Model Building Activity 5

Hello,

I cannot figure out the formula for Bonus and other line items for Level 1 Model Building Exam - Model Building Activity 5

 

I created the EMP03 Employee Drivers by Role module and added the department and role to it.

In activity 5, we have to change the module EMP02 Employee Expenses "Bonus" line item formula to fetch the bonus from EMP03 Employee Drivers by Role module. 

 

Your help on the formula is greatly appreciated.

 

Regards,

Harsha Rappan

 

1 ACCEPTED SOLUTION

Accepted Solutions
HarshaR
Occasional Contributor

Re: Level 1 Model Building Exam - Model Building Activity 5

Thank you for the giving the right direction, I had to come up with different solution, for some reason the Role list did not accept the top level, so i deleted the Role list and while importing the role list i removed the Roles header and after the import was complete, i manually entered "All Roles" and it worked.

 

Regards,

Harsha Rappan

View solution in original post

3 REPLIES 3
HarshaR
Occasional Contributor

Re: Level 1 Model Building Exam - Model Building Activity 5

Any Idea what the screen shot message means? I created a Role list and I added the Roles to SYS08 Employee Details module, now every employee in SYS08 Employee Details module has a role assigned to it.

 

As per the Level 1 Model Building Exam - Model Building Activity 5, we are to change the bonus formula of the 

EMP02 Employee Expenses module to get the bonus by department and role from the EMP03 Employee Drivers by Role module, this module has Bonus by department and role.

 

Attached is the question and here is my formula which is not working.

IF Employed? THEN Salary *  ‘EMP03 Employee Drivers by Role’.Bonus %[LOOKUP: ‘SYS08 Employee Details'.Department, LOOKUP: 'SYS08 Employee Details’.Role] ELSE 0

 

Any help is greatly appreciated.

JaredDolich
Moderator

Re: Level 1 Model Building Exam - Model Building Activity 5

@HarshaR 

We cannot give the answer to questions but let me at least try to point you in the right direction.

The error you're getting suggests that you forgot to add a top level to your Roles list. "All Roles" would be a good choice. I've seen the role list get build many different ways and unfortunately, it's very easy to accidentally create a staggard list. If you already have an "All Roles" in your list then you'll need to do one of two things. 

  1. Create the Top Level "All Roles" and move all the roles underneath the top level. Delete the staggard parent. This should prevent you from losing any data in your SYS08 Employees module.
  2. Delete and rebuild the Role list but this time create the top level first then import the roles. You will lose your SYS08 mapping so you'll also need to reload the roles into the SYS08 module.

Jared Dolich
HarshaR
Occasional Contributor

Re: Level 1 Model Building Exam - Model Building Activity 5

Thank you for the giving the right direction, I had to come up with different solution, for some reason the Role list did not accept the top level, so i deleted the Role list and while importing the role list i removed the Roles header and after the import was complete, i manually entered "All Roles" and it worked.

 

Regards,

Harsha Rappan