Planual Explained - Day 24

Highlighted
Master Anaplanner/Community Boss

Planual Explained - Day 24

“Rule 2.04-03": Article 2, Chapter 4, and Rule 3 – “Keep the default view clean”. “Keep the default view as is, no hiding, filtering, or conditional formatting. It goes against AUDITABALE elements of PLANS if you wish to go against this rule

Here is how it was done in Pre Planual Era:

We used to do all sorts of filtering, Hide/Show & Conditional Format on the default view of the modules without creating saved views.

Misbah_0-1591872969132.png

 

What is wrong with this method?  It becomes difficult to audit such modules.

Here is how it should be done in Planual Way:

When we have to publish anything on the dashboards it should always be Saved Views, exceptions being Lookup modules, leaving your default view clean. We should not apply any Filter, Formatting, Show/Hide or Select Levels to Show on our default view

Misbah_1-1591872969142.png

 

 

1 REPLY 1
Highlighted
Valued Contributor

Re: Planual Explained - Day 24

  • This is an interesting rule. I have a "technical" reason why we should keep the default view "clean and pure"🙂

    Anaplan default setting when creating a new module is to place the Time dimension on the columns.
  • While developing I don't always need the Time dimension to be on the columns, I prefer seeing all the line items or all members of a list.
  • In many instances, I create the model without changing the Times dimension location from columns to Page Selector.
  • Once the model is created, I quickly use the pivot to put the time dimension in the Page Selector area then save that as a default view (in my mind there is no filtering, hide/show, or conditional formatting)
  • What I discovered is that when I do so, the value of the Time dimension doesn't sync with the rest of the modules in the model but rather remains on the initial value it had when I created the default view.
  • This, of course, was providing a lot of confusion since the time for the module(s) was completely out of sync.  

 

You can read more about this issue in this post.

 

I now either change the time dimension to Page Selector while creating a module or create a saved view.

 

The moral of the story ...
Listen to Best Practices 🙂 

Einas
"Give a Man a Fish, and You Feed Him for a Day. Teach a Man To Fish, and You Feed Him for a Lifetime"