Simple Import failing and cant see why

Regular Contributor

Simple Import failing and cant see why


I have a saved view in one Module in Finance Model and it has about 20 fields, one of which is Unique called 'NPD Ref Code'

I am importing this view into a list in NPD Model, using 'NPD ref Code' and selecting 'Name only'



It is giving me an error on a record 

"New property combination found but name or code already exists"


But it does not exist, I have checked, (100% certain it does not exist)

To quantify I manually tried to add this ref to the list, and it lets me.


Any suggestions, please?






Certified Master Anaplanner

Re: Simple Import failing and cant see why

I think is beacuse enabling the option "Adjust Duplicate Names" you are getting to the point that you will have two names "Name1" and "Name1~(#)" mapped to the same code. Although you are using Name only, two items in a list cannot have same code. Can you share the error log perhaps? (if is not too confidential)
Regular Contributor

Re: Simple Import failing and cant see why

It's not that, I had it with that unticked and tried both to see if there was any difference, there wasn't


I did, however, remove the Code from the import all together as I am not needing it and that has solved it.


Duplicate codes were the issue, such a simple thing...





Master Anaplanner/Community Boss

Re: Simple Import failing and cant see why


It is best practice to use codes for imports to Numbered Lists rather than combination of properties


1. The import is much faster

2. It makes the list much easier to use downstream


So if you can try and deal with the duplicate codes, even if that means generating a unique key in the data