File delimiter changes after API execution


Hi Experts,

We use Anaplan connect 1.4.4 to import data from SQL. we noticed that after import execution the file delimiter default itself to "Tab" even though it is set to "Comma" delimiter. this is weird. 

Interesting part is even if the action changes from comma to tab further load using the same API call works when it was imported using Anaplan client 1.4.4 but this is not working when this action is called from AWS API (v2)

@Echo off

set ActionName="1.1 Current date upload from SQL"
set ActionFile="Current_Date.csv"
set ErrorFile=Current_Date_Error.txt

set Operation=-auth %AuthUrl% -file %ActionFile% -jdbcproperties "%JDBCpath%\%JDBCFile%" -import %ActionName% -execute -output "%Errorpath%\%ErrorFile%"
rem *** End of settings - Do not edit below this line ***
setlocal enableextensions enabledelayedexpansion || exit /b 1

cd %~dp0
if not %AnaplanUser% == "" set Credentials=-user %AnaplanUser%
set Command=.\AnaplanClient.bat %Credentials% -workspace %DatahubWSID% -model %DatahubModelID% %Operation%

cmd /c %Command%

Action is configured as "Comma" delimiter


After executing the API import, the delimiter automatically changes to "TAB" from "COMMA"


Please suggest why delimiter changes after Anaplan connect 1.4.4 API call







  • Hello @Sivasankar,


    Wow this is an interesting situation. CSV files are comma separated or comma delimited. So the comma delimiter here makes sense. 

    Regarding the issue of automatic changes to Tab delimited once it is set to Comma after running the action is interesting.


    I have a few ideas: 

    1) Can you please try recreating this import from scratch?


    2) See if the issue persists.


    3) If so, this would be a good issue to raise with Anaplan Support at


    Hers is another thread worth reading-

  • @DaanishSoomar yes tried to create one import from scratch but result is the same


    Will forward this request to support team




  • Awesome @Sivasankar,


    1 other thought came to mind, does the data load successfully after the delimiter setting changes from Comma to Tab?


    How many rows of data do you have? I am wondering if this is because there is only 1 element of data in the file which is "Current Date" and Anaplan automatically treats 1 row of data as "Tab" delimited. 


    Anyway yes going down the Support route would be the best way forward to see if this is a bug or intended behavior.

  • @DaanishSoomar yes even after changing the delimiter it loads with the same batch using Anaplan client 1.4.4. but when we try to load data using the same action from AWS API (v2) it prompts error




    The dimensions in the target module do not match the import definition."],"$type":"Detail"}]}




  • Got it @Sivasankar. Support case is the best route forward! 

  • @DaanishSoomar do you know how to forward this request to support team from here




  • @Sivasankar -Yes what you can do is you can email Then link this thread in your email so they can help out from here. Emailing support is best because it will formally log a ticket in their system so it can help Anaplan track similar reports and maybe find a similar solution or route it up to higher levels if needed. (I used to work on that team). 

    They will very much be willing to help and emailing support would help Anaplan manage the case more efficiently! 

  • Hi

    I am facing similar issue, any update from support?