I am very messed up on my Anaplan Module. When I import the data I follow the example exactly but then I get an error saying Invalid name

Best Answer

  • abhi1017
    Answer ✓

    @ZachChurch  Region list also has been cleared out. 

    Follow this:-

    1. Import Region

    2. Import Country 

    3. Import Location

    This is a hierarchy hence you need to check if the parents are present or not and then go ahead with importing the child lists.


  • Hi @ZachChurch,

    can you share screenshot or provide more detail? What is your source and target? How do you import data? 

  • After this mapping, it gives the error invalid name



  • @ZachChurch  Can you share the screenshot of the error?

    I just tried myself and it worked well with exactly the same mapping.

    Is your error related to Parent perhaps? Did you set-up hierarchy correctly? Is R1 Region parent of G2 Country in your model?




  • Hi @ZachChurch 


    Is your G1 region list populated?

    Could pls share screenshot of your G1 region list.



  • Pls. clear the country list.

    Now, While creating an import action select Name or code instead of code.

    Guess this should work Else pls. share screenshots of the country list and action.

  • I cleared the list and then followed what you said and in the end it gave me an invalid parent error The top picture is what I ended up with2021-04-02 (46).png2021-04-02 (45).png2021-04-02 (44).png2021-04-02 (43).png2021-04-02 (42).png

  • YESSSS it finally worked thank you so much!!!!!!