Question on how to map miss-matching dates

Hi,

 

I would like to know how to match my flat file's when my dates on my flat file and Anaplan do not match. Usually I end up having to manually match them. Please advise. snap shot attached below. 

 

neg177_0-1618000039910.png

 

 

 

Thank you  

Best Answer

  • Neg

     

    I don't believe you are in the module you are importing the data to for a couple of reasons:

    • When importing into a module with native Time, it looks like this
      2021-04-09_17-02-24.png
    • The list you are importing to has the dashes, the "mapped to" matches the list members of the list.

     

    Rob

     

     

Comments

  • Hey @neg177 

     

    Help with your mapping, why are the targets the same date separated with a "-"?

     

    Rob

  • Hi Rob,

     

    I'm not sure why the dates are separated with the "-", We tried to export data from Anaplan to add additional data in Excel, and when we tried to import the csv file back into Anaplan we saw that the dates then had the separation. Leading to the manual mapping. 

  • @neg177 

     

    So that is very odd.  In the excel, how are the dates formatted?

  • We changed the dates to be formatted to match Anaplan. Shown in the Snap Shot below. We also tried other formats and still not automatically mapping the dates. 

     
     

     

  • @neg177 

     

    Can you get a snap of the Excel?  Excel is routinely the devil because it changes the format fo the cells.  Remember, when mapping dates from Excel, it is best to use a number like 20190501 (YYYYMMDD).

     

    Rob

  • Yes, attached is the snap shot of the Excel File. 

  • @neg177 

     

    Can you click in one of the cells with the date and take a picture of that?  Also, you might want to check out the delimiter when you uploaded the file.

  • attached is a pic of the data in one of the cells. Also to eliminate that delimiter issue should we import it as a txt verses a csv?  

  • @neg177 

     

    And can you post the mapping tab on the action?

  • attached is the mapping tab on the action we are trying to perform. 

     

    Thank you 

  • @neg177 

     

    The first tab, the Mapping tab and I just realized, you aren't using the Native Time, are you?  If not, why not?  And do you have a code on this list?

  • @neg177 

     

    Lastly, it is not the source that I think is the problem, it is where it is going or landing that is the issue.  Can you take a look at the list members of your fake time and see why those might have a "-" in it?

  • I'm not sure what you mean by Native Time? 

  • Are you using the regular Time dimension or a custom list?

  • we are using regular time.