Importing HR Data issue via Script using Process in Anaplan.


Dear Expert ,

I have to import Hr Data via Anaplan connect Script by using the Process which has been created in Anaplan with Import actions. But while importing its getting failed error as shown below . when i check Process and tried to Execute directly via process i could able to see we need to pass the Period while executing .Does it the reason which is creating issue to load via Anaplan Connect Script. Kindly Help me with the Solution to proceed.

Screen of Process load in Anaplan and script error is attached .


Kindly Advice.

Warm Regards







  • Hi @Deepu,


    You are right the error is because of the period mapping. Whenever you are running the process through the scripts you have to map the time or the period other wise the dimension does not matches and the script fails. 


    The files will get uploaded but the actions or the process will not run de to the mapping. I don't know how you will do the mapping in the Java code but in python - {'localeName': 'en_US', 'mappingParameters': [{'entityType': 'D4_Day.S ADI', 'entityName': '2021_05_04'}]} you need to map. entity type is the date subset and entity name is the today's data because Iam uploading for today.



    Riyaz Pasha




    Riyaz Pasha

  • @Deepu  the issue is coming from the fact that the import is setup for Time list with the option "Ask each time import is run". I presume that your data file does not contain a column with the month. 


    This can work fine if the file is loaded manually from a dashboard....but you have issues when you try to run the action via Anaplan Connect. 


    I personally don't know how to pass to an Anaplan Connect script the parameter for an action setup with the option "Ask each time import is run".


    I would try to ask who creates the export CSV file to add a column with the month and map the month using a column from the CSV file. 


    If this not possible, I would change the approach:


    1.  in a system module: setup a line-item formatted as Time and chose there on which Month you would like to import the data

    2. Import the file in a temporary module (without the Time)

    3. create a new import action from the Temporary module (without Time) + line-item setup at point 1. and import data into your final module. 


    This would create a new step into your import data process but you will not need to choose via Anaplan Connect script on which month you will need to import the CSV data.


    Hope it helps


  • Deepu

    Dear Expert ,


    Actually I passed the time/period parameter in Script as shown below , but I am getting the error as

    "2021-05-06 10:42:13 INFO  [c.a.client.Task     :-1   ] 14164 |--   Invalid date or timescale identifier: 24882
    2021-05-06 10:42:13 INFO  [c.a.client.Task     :-1   ] 14164 |--   value - Jan-2020 "


    I have pass the value in script as shown below I also tried with jan-20 but below erro coming  :


    "set Operation=-debug -service %ServiceUrl% -auth %AuthUrl% -workspace %WorkspaceId% -model %ModelId1% -chunksize %Chunksize% -file %FileName% -put !FilePath! -process %ProcessName% -mappingproperty Period:Jan-2020 -execute 


    my Import file is having data for line item as shown below , its a HR Data .

    1,06/22/2020,12/31/9999,00004235,74000387,First Name,Last Name,51,06/08/1998,06/08/1998,ZONE VICE PRESIDENT,37.5,Appointive Officer,true,Regular Pay,1010,GRADE Z,300000,100270,ZM - Zone Manager,,Active,No,No,1,Yes,AZ,1


  • I think it is probably just the value passed in not matching a period name in the timescale. Have you tried -mappingproperty "Period:Jan 20" (note double quotes)?