Confused as to why this import is not mapping automatically


I am trying to build a process where end users can upload values into an input module. Ideally they can export out the template from Anaplan and then update the values and then import the updated csv into the Module. However when I am trying to create the import action the automatic mapping for the field Sales Plan Region is not functioning as I would expect. Picture included. Any ideas why this field would not map automatically? 



Best Answer

  • JaredDolich
    Answer ✓


    Okay! That's it. The numbered list. Always a few gotchas. So, in order to import the data you'll have to replace the "display name" in your import file with the CODE instead. Alternatively, you could make the CODE the same as the display name in the List. Either way, the only way to import that is to utilize the CODE.

    Good detective work!! 


  • @dylancolliflower 

    Hopefully this is something simple. Some suggestions:

    • My best guess is that there is a special character showing up in the source like a [tab] or a [space]. Try using the TRIM function in Excel to remove them.
    • If you load the same file manually does it map correctly? If yes, then rebuild your import action and make sure you save it as "EVERYONE". 
    • Is this a numbered list? If it is, then you have to use CODE. Anaplan does not map to "Display Names". Your choices for numbered lists are CODE or the system generated list item.
    • Last idea is to use the CODE rather than the list item. As a practice, I almost always use CODE.

    See if any of those help. If not, let's take a look at your mapping screen for the import.

  • @dylancolliflower 


    Please don't take the is wrong way, but why would you want users to export a module, update it in Excel, and then import the data back into Anaplan?  I would think it would be much simpler for them to just update the data within Anaplan, and in doing that, you remove the actions that could be blocking other users.



  • This process is because there are numerous rows that would need to be manually updated in Anaplan. This is a stop gap until we get better source data. 

  • I checked and trimmed the sales plan item field in excel and it still does not map when I do it manually or in the process. It is a numbered list but not sure where in the import wizard I can choose to map by code. I don't see that as an option anywhere in this dialogue. 

  • Thanks @JaredDolich Jared! Had to modify my initial export template to pull code instead of display name so that the eventual import would be able to map on the numbered list. 

  • @dylancolliflower 

    Awesome! Great job!