Can't upload a new import data source for part of actions


When I tried to upload a new import data source file(.cvs file) for a action, I find it is void, no any error message, It looks like everything is working, but when I want to edit the action after upload new source file, still prompt "The uploaded file is no longer available; please upload the file again".

And I found it is working well for part of actions in the same model.

Has anyone ever been in a similar situation? or any good advice for this?

Best Answer

  • jasonblinn
    Answer ✓

    Make sure the file is named identically to what the file was called when it was originally imported and created the Data source. Once it is saved as the same name, you can go to Import Data Sources > New Source > Upload New File, and then you can edit the existing action since you have re-loaded the file.







  • Hello @stephenxia 


    This is normal. Private files are kept in the cloud only for 48 hrs since it was accessed last time. 


    If you want keep it as a default file for long time, mark the default file to be "Admins only"


    Further details can be found here.


    Hope it helps.




  • Yes, I understand.

    My question is, I did the "update new file..."  and immediately tried to edit the action,  still prompt "The uploaded file is no longer available...."

    Update new file operation was not successful...

    But in the same model, part of actions can update new file successfully.


  • Hi Jason


    Sure enough, it's the question of file name, which isn't exactly the same as the original file name.

    I modified the file name and updated successfully.


    Thanks a lot!