"Failed to Create Item" error in NUX




In Dev environment, I have two general list "L1 Maintenance Category" and "L2 Maintenance Detail". L1 got a Top Level Item setup and has been setup as parent hierarchy of L2. 


In NUX, two Form (or button), B1 and B2, have been created to add list item into L1 and L2 respectively.

Button B2 works fine, user can click the B2 button to add a new item into L2 list. However, B1 returns "Failed to Create Item" error.


The User and I got Full Access to the model, we got the same error message.



I have tried to manually add a new item into L1 from model builder screen and it is working fine.


Where should I look into to resolve this issue?




Best Answer

  • Ivan_Lo_
    Answer ✓

    Thank you for the reply.

    I have raised a support ticket and it has been solved.




  • Misbah



    If it was in Prod Environment I would asked you to review if L1 is Production List. Having said that here is the thread which discusses that it was a bug and had been fixed.


    As a workaround see if any of these options help. If L1 is Numbered list try creating L0 as Parent of L1 instead of having Top Level, it should work but if L1 is a non Numbered list see option 1 & option 2 below.


    Hope that helps


  • What was the issue? I just ran into the same problem with a form on a worksheet without any obvious reasons. Interestingly it works normally on a board.

  • Hi Phillip - this pobably won't help you, but you can also encounter this issue if your model is in Deployed mode and the list you're trying to modify is not Production Data : )




  • It was actually DCA. 🙂 I forgot that Forms don't work (or have severe issues) when using DCA driven line items. In my case I had a form to enter new investments with the option to sign-off the investment for further approval directly in the form. That caused that new items couldn't be created because of "read" access.

  • Thanks for your tip to check the DCA line items. Kudos to you!
  • Hello @Misbah,


    I actually have the same issue with NUX forms "Failed to create item" and it appears on Board page, while trying to import an item into numbered list using a parent. I am wondering what the issue could be, as this was actually working before, and it just stopped at some point. What the issue could be from your experience? 


    Thank you!


  • Misbah



    Strange! You saying it was working before and now it stopped working? Assuming your list is a production list - 

    On your FORM creation window do you have other lines that end users are populating/inputting - upon which DCA may have been applied. 


    Miz Logix

  • @Misbah 


    Yes, the list is marked as a production one. And no, no DCA is applied on the input lines on the Form window. That's why I am saying it is super strange that it worked before and without any change it just stopped at some point. Probably if I recreate the forms it might work again. 🙂

  • Hello @Ivan_Lo_,


    I have encountered the same issue few weeks ago, here what I found on this issue: 


    Case 1 : 

    If your adding a list item into the list then might be your model storage capacity is exceeded. Try to delete one of the list item from the and try again. It will work normally. 


    Case 2 :

    If Case 1 is not the problem then follow the @Misbah 's steps it will help you.