More than one value for non-numeric cell - Boolean




I have a input module published to a dashboard that allows planners to enter new headcount for their departments (Planner Dashboard TBH Input - DB View). I import this data into another module that doesn't have the department dimension (To-Be-Hired - Input). The purpose of the dashboard module is to prevent planners from overriding and seeing each other's inputs. I have a boolean that determines if the the new position is a backfill. When I import into the "To-Be-Hired - Input" module, I get the "More than one value for non-numeric cell" error on only some of my boolean items. Anaplan will not display what rows are causing the error. While the import appears to work each time, my planners get confused seeing an error message, and reach out to see if their changes went through. I would greatly appreciate any assistance!


"Planner Dashboard TBH Input - DB View" Module:



Action to Import:



Error with Import:



Unable to display failed rows:



"To-Be-Hired - Input" Module:


Best Answer

  • aakash
    Answer ✓


    Let me first explain what is the cause of the error. You have a source module with a dimension that is not there in the target module. So let's say you have only two values (DEPT1 and DEPT2) for in your import source, let's say you just have two versions(V1 and V2) and two Row IDs(R1 and R2). When you do the import your source module looks somewhat like this

    DEPT1 - V1 - R1 - Boolean Line Item

    DEPT1 - V1 - R2 - Boolean Line Item

    DEPT2 - V1 - R1 - Boolean Line Item

    when you map your versions and row ids , the target module finds two entries for same combination, (Row 1 and Row 3). Had it been a numeric cell , the target module would have just taken the sum of two rows, but for all other line item types , it is confused, which row to take.


    Now let's talk about the resolution. You do state that your requirement is to solve the concurrency issue between different users and you are achieving this by using departments (I assume only one user has access to one department), now what you can do instead is to use a system users list instead of departments in the source module and keep 'Show All Users' option as 'OFF' in the source blueprint, and your problem will be solved, every user will be able to import the data exclusively (Notice the difference between the mappings when you use 'Users List'). Let me know if this sounds doable and you need any more help on this.



    Aakash Sachdeva


  • Hi @CommunityMember115839 ,


    > This error should be due the fact that: for the same version and Row ID, there are more than one values in the Backfill column (some true, some false, which must be from different departments). Therefore, system cannot decide the department from which the input is to be taken.


    > You might want to segregate the target module also by including the department dimension, and subsequently structuring it according to the required report. To keep the users from seeing/editing inputs of other department, you can use role based selective access


    >It looks from the screenshot that, the source module view has summary items as well (Ex: Total AU), which cause issues. You might want to create a saved view with just the lowest level items to import.




  • Vinayvm, 


    Thank you for the quick reply. I made changes to the saved view to eliminate the summary items hoping that was the cause. It did not fix my problem. If I have no subsidiary views in either module, why would just the boolean be giving me this error? I set the formula to FALSE to make sure everything is cleared out of the boolean, even though I do have a clear action within the process. Adding the department dimension to the target module is not really an option due to sparsity concerns. I've included screenshots of both module's blueprint views as well.


    Planner Dashboard TBH Input:



    To-Be-Hired - Input (Target):



  • Hi @CommunityMember115839 


    How do you deal with another entry in row 2 with the same input as row 1, but with a Backfill? = FALSE


    If you only want to export the first instance, then you can do the following:

    1. Create a line item, 'Concat Text' that concatenates the text of Accounting Unit, Expected Start Date, Pay Class, Employee Status, Payroll Company. You can use CODE to extract the text.

    2. Create a line item, FIRST? = ISFIRSTOCCURRENCE(Concat Text, 'Row_ID (To be hired) - Active')

    3. Create a Saved View that filters for FIRST? = True

    4. Use this saved view as the import source to your target module.