Importing data with two dimensions?


I'm playing around with Anaplan to learn better how it works.  I want to import population data (see below).  The data in the csv has country on the rows, years along the columns and the respective population it the cells.


In Anaplan, I have created a list for the countries (with the codes) and I created another list for the years.  I created the years list manually because I could not figure out how to create a time dimension with only years and with so many years (I'm guessing its not supported and that kind of makes sense given this is for planning not BI).


I can't figure out how to import this data.  Any suggestions?

Best Answer

  • anand.shekhawat

    Hi @StephenG ,


    In Anaplan you have two types of time settings , the first one is the Model Calendar and the second one is time ranges. From here you can set all your planning period. To understand better kindly go through the Anapedia by clicking here


    Now to understand how to upload this population data into the Anaplan.

    I would not recommend using the Anaplan built in time as the data range is from 1960 to 2020 as Anaplan supports the maximum extent of around 100 years with the earliest being FY1981 and the latest FY2078. So the option left is to use a manually created 'Year List'

    So to import the population data file you will be needing 2 Lists 

    1) Country 2) Year List

    Step 1) Create both the lists

    Both the Lists might look like the below screenshot



    In the above lists I have included all the Countries from the File and Years ranging from 1960-2020

    Step 2) Create a Population data module using both the above dimensions.

    Step 3) Now import the csv file into the module. The mapping of the same would look something like the below screenshots




    The Country and Time will automatically get mapped, but you have to map the population line item manually as the name are lil bit different.

    Step 3) Now run the process, you will get the data into the system 

    You might see the below dialog box


    Ignore those 220 data fields because we have created the year 2020 as well, but there is no data in the csv file for those 220 Countries.

    Also make sure that your data is clean before importing.


    Sorry for being so much descriptive 


    I hope it helps.





  • Thank you for being so descriptive!  I was missing the manual mapping of the population.  That did the trick.

    Thanks again.