Anaplan api get lists issue

Hi guys 

 

Is anyone having issues with retrieving lists end point via api ?

 

I am getting below error 

 

https://api.anaplan.com/2/0/workspaces/myworkspaceid/models/mymodelid/lists
{'Authorization': 'AnaplanAuthToken mytokenvalue', 'Accept': 'application/json'}
{
"status": {
"code": 404,
"message": "Not Found"
},
"path": "/2/0/workspaces/myworkspaceid/models/mymodelid/lists",
"timestamp": "2021-07-13T08:32:30.477100Z"

 

 

I have checked following 

  1. workspace id is correct
  2. model id is correct 
  3. auth token works ( i have made calls using same token to get list of workspaces and models)

one thing i noticed that on api document retreive request url is HTTP instead of HTTPS . have tried that as well doesnt work 

karanAMP_0-1626165576771.png

any idea ?

Comments

  • update 

     

    I am workspace admin and can successfully log into model and have full access 

    i even tried content_type : application/json instead of accept 

    still didn't work 

     

    any help will be greatly appreciated 

    karanAMP_0-1626218904982.png

     

  • any help @ben_speight ??? I have hit a brick wall with this 

  • Normally that response would suggest incorrect workspace ID, incorrect model ID, unsupported API version or no access to that model. I presume you cannot access other resources below model level eg files?

  • @ben_speight  yes i cannot access anything below model level via API

     

    The odd thing is I have full access (workspace admin) to the model and can access everything ???