Number values getting inflated by 10x when importing from file


Hi all,


I'm having an issue when loading a data file to a client's Data Hub. The target module has several line items, some of which are number formatted. When I load the source file one of the numerical columns is getting inflated by 10x once it's populated in the target module.


For example, there's a value of 468,408.66 (formatted as 468408.66) in the source file. However, once the same value is populated in Anaplan via the import action created for it, the value is inflated to 46,840,866.00. It seems as though Anaplan is misinterpreting the location of the decimal point.


I've tried adjusting the number format configuration many different ways, adjusting the language in my browser settings, and changing the number format in the source file, all to no avail. This also happens when someone on the client side tries loading the same file.


Has anyone ever run into this type of behavior in Anaplan before?

Best Answer

  • jasonblinn
    Answer ✓



    In the Import Source, can you confirm that the decimal separator is correct? 


    Secondly, can you confirm that your source file does not have that intersection 10 times in it? If it has all of the same dimensions, and it has 10 instances that would hit the same cell, it will add them together as part of the load. 


    For example: Here I am importing into an Employee list, dimensionalized by Time. This is my file:



    Since there are multiple instances of Employee 1 and Jan 18, it is adding them together once I load the file.









  • @JMiddleton Can you check the Format for the line item which is making it 10x. The unit should be set to None.

    Also you can try loading data without decimals to check whether it is still making it 10x.






  • I can confirm that the Unit for the line item is set to None. This has had no effect on the issue, values continue to populate in multiplied by 10. I should also note that the decimals need to be included in the data load.



  • I can confirm that the decimal separator is set correctly. I have also tried changing the thousand separator to None to reflect the value as it's formatted in the source file but this also has not resolved the issue.

    I can also confirm there are not ten instances of the same value, it is the values in this specific line item that are getting inflated by 10x. It seems like it is simply that Anaplan is misinterpreting the location of decimal in the data but I can't find a configuration in the line item's formatting options that will make Anaplan interpret it correctly...



  • Discovered the solution. Apparently the Decimal Separator in the Data Import Source was set to "Comma". Changing it to "Dot" appears to have fixed the error.