Level 1 Model Building Exam - Model Building Activity 6

edited December 2022 in Academy Discussions

Hello all,

I have been trying to work through Model Building Activity level 6 and cannot seem to understand why my lookup formula is off. I am trying to add a formula to REP04 that shows Total Salary expenses by Region and Role. The formula I am using is 'EMP02 Employee Expenses'.Salary[Lookup: 'SYS08 Employee Details'.Region, Lookup:'SYS08 Employee Details'.Role] but it receives an error. 


How I understand it is that 'REP04 Employee Expense Summary'.Salary is my target and 'EMP02 Employee Espenses'.Salary' is my source module. Because EMP02 does not contain Region and Role I need a mapping module/s to achieve my goal. I am trying to use 'SYS08 Employee Details'.Region and 'SYS08 Employee Details'.Role for mapping but receive an error. What am I missing? Do I need to be using a different module? If more details are needed please let me know. Thanks for any help!


Error message: Format of mapping used for lookup doesn't match any dimension of the source


Helpful reference post I believe is relevant: https://community.anaplan.com/t5/Academy-Training/Altering-Line-Item-Formula-with-lookup/m-p/88856#M2524











  • aykcos
    edited December 2022



    I have set up formula for Salary without having a problem. But I am facing with the problem with finding correct formula for other line items in this model like "Bonus", "Car Costs", Phone Costs" and "Medical Benefit".


    Lookup function does not work in this module because of dimensions mismatch. But SUM function does not work also.


    Any hint for this please?

  • Bin.Zhou
    edited December 2022
    have you got answer for the formula to sum up Bonus? I run into the same issue as you have.
  • aykcos
    edited December 2022

    I solved this problem by considering the differency between dimensions. You should pull data from another module and convert it by correct mapping considering the dimensions. 


    Target module's dimensions:

    E2 Employees#: Active?


    Line Items


    Source module's dimensions:

    E1 Departments


    Line Items


    So, you should take the first 2 dimensions of source module into account for mapping.

    I hope this helps. 

  • kunle
    edited December 2022

    I am struggling with Activity 6 despite following some of the suggestions on the thread. Please can someone suggest a hint as to a way out.

    Here is the error i am seeing when i create my formula:



    Below is the Blueprint view on my REP04, EMP02 and SYS08

    REP04 Blueprint view.PNG

    EMP02 Blueprint view.PNG

    SYS08 Blueprint view.PNG


    Thank you.

  • egunerhan
    edited December 2022

    Role item probably not listed correctly 

    To solve this problem 

    1. Go to SUM: SYS08 Employee Details

    2. Look at the format of "Role "

    3.Make the changes as below 


    Type: List

    List: Role


    Good luck to whoever may need this explanation!

  • nileshs
    edited December 2022


    When I use my SUM formula I am getting blank values.


    Also I do not see any data in sys08.region and sys08.role. its blank. how to get the data here. I have formatted them as list G1 region and E3 role.



  • xbabykangaroox
    edited December 2022

    One of your main issues on this is that the range of the sum has a value in SYS008 that is not a list or a date. I would make sure that you are ordering your line items properly or properly referencing the correct format for any information in that range in blueprint view!

  • Mallika1001
    edited December 2022


    @NoahBG tried using your SUM Logic but the answers are incorrect, the formula is getting validated but both answers got wrong

  • RavinderB
    edited December 2022


    The formlas requires the SUM function and not LOOKUP. Please explore Anapedia about the techical details around the SUM function.

    I would also explore the line items in the SYS08 module to check the formatting of the items you are summing:

    Screenshot 2022-09-08 at 09.29.19.png

    If required check the general lists assoicated with these line items. Does you role list have a top level of All Roles?

    Screenshot 2022-09-08 at 09.30.36.png

    Is your EMP02 module updated correctly to reference data in the EMP03 module: e.g.

    Screenshot 2022-09-08 at 09.32.44.png


     Try working backwards from you issue to see if the dependecies are correct. If not you will have to amend them. This will then work.


    Thank you



  • JillianKelli
    edited December 2022

    Hi, I'm also getting blank values. Did you ever figure this out? Thanks!

  • NoahBG
    edited December 2022

    Hi JillianKelli,


    As a few replies here have posted my issue was using the LOOKUP function when I should have been using the SUM function. You can see the response I marked as the answer here: https://community.anaplan.com/t5/Academy-Training/Level-1-Model-Building-Exam-Model-Building-Activity-6/m-p/114835#M3234

    If this does not resolve you problem other responses lead me to believe there is likely a formatting issue with your data due to pulling from an incorrect module or incorrect mapping. Best of luck and you got this!