Experience with Cloudworks model to model integrations


Hi All 


I have noticed below with cloud works model to model integrations so far . Unsure if anyone else have noticed these as well


  1. when setting up integrations page refresh is slow and hangs 
  2. when manually starting integrations i get message failed to start integrations randomly and after trying couple of time it works 
  3. integration runs very slowly i.e. these are queued sometimes for 10 - 20 minutes 
  4.  integrations takes 10 20 times more to execute .i.e if i kick a process in anaplan which takes let say a minute in cloud works it can take upto 10 or 20 minute even though it is as simple as uploading a list 


  1. we had a test model where we were testing cloudworks integartions . We then archived the model however cloud works were still running in the background for some reasons . Cloud works tried looking for the model and consumed all the memory which brought down the entire workspace down . Users were unable to log in . So we had to disable cloud works integrations for that model manually . 


    Hope this helps someone 

So far its been bit underwhelming for us . Has anyone experienced similar issues ?


  • @karanAMP 


    No, it is slow but it is not 20 times slower. I would say raise a ticket with Anaplan support

  • We had the issue where the actions would work on a non-deployed model but not on a deployed one... which is frustrating. It could be a real game changer as would reduce our dependency on external scheduling to move information about our environments.

    Not sure if that got cleared up or not - I haven't been too close to it.

  • I would also think that these are jobs that are going to be run "outside of hours" so if your data goes into datahub at XX:xx time then you can use Anaplan to run imports afterwards particularly if it impacts a collection of models.

    Or you just want to run something without needing to load up the model!

  • @Misbah yes it can be 20 min slower here is a screenshot to prove it 




    same process ran twice (it has only action in it which brings in 1 list with less than 20 items in it ) model fully loaded as well 


    20 min duration and 10min duration 


  • @andrewtye I haven't tried this in deployed mode yet . I will try and post it here 


    In my case models where loaded and ready both source and target 


    I agree this could be a real game changer however currently it seems like there are issue with this version of cloudworks . Atleast i am facing it 

  • Hi @karanAMP 


    Cloudworks is more mature from an AWS integration standpoint, and expanding in another integrations bit in the early stages, will get more mature soon.
    I did notice the slowness for sure; a simple import action from data hub to spoke model takes less than a minute (tried two methods - using Informatica cloud and manual run from spoke model).

    Cloud works took 8 min for the first time and 7 min the second time, not sure how the resources are allocated for cloudworks.

    Scheduling is another good feature that will grow more from here.




  • This is being actively investigated. Thanks for your feedback.
  • @karanAMP For me, Cloudworks is already a game changer. One of the processes which we were running using an external vender Anaplan connector used to take more than 10X time than the Cloudworks integration and I do agree with @andrewtye that we would be scheduling these jobs off-peak hours, I guess we would be fine with some lag but definitely not 20X.



  • DibB

    @karan Can you please create a support ticket? Your issue sounds similar to something we are currently investigation but we would like to be doubly sure. Thank you for your patience!

  • DibB

    @andrewtye This sounds like a known issue that we plan to address in our release next month. In order to be sure, you might consider opening a support ticket with the specific details. Thank you for your patience!

  • Ah yes... it might've been our ticket that raised it. I'll keep an out for that and let the team member now.

  • We have put in a few fixes to improve the performance. Can you please let me know if you are still experiencing the same challenges?

  • @andrewtye We have put in a fix to address the issue. Can you please confirm that the issue has been resolved at your end?

  • @DibB  thanks for the update. Will test and update. Might take some time as i turned it off and reverted to other orchestration methods

  • @DibB - Woohoo! I've run a couple of items and it all appears to be working in the background all ok, am just getting another team member to run a slightly different process in another model just to be doubly sure. But so far, so good!

    Have some virtual cake.



  • @DibB : well this is odd, in my model the process is running fine and in history I can see all the impacted list items and module inputs, etc. however in my colleagues model whilst I can see that the actions have been run there isn't the detail behind it even though there are items impacted by the process and when it's run manually the changes flow through in the way you'd expect them to

  • @andrewtye We might have to investigate this scenario. Can you please have a support ticket created?

    Also, you might want to check out the Common Errors and Solutions section in Anapedia https://help.anaplan.com/f6f94935-6f97-4530-91fb-19ddc06a746c-Common-errors-and-solutions

    e.g. Is this an Export that involves Selective Access?


  • @DibB - it isn't an export. Will get a ticket raised up today. We even deleted the old integration and recreated it in Cloudworks to see if that might help. Is a relatively straightforward import into a list from another list and then delete those items from the second one. The one that does work has about 10 steps in it and works perfectly!

  • @andrewtye 


    Why are doing an import from a list and not view and then doing a delete?  You should have known I was going to pounce on that!  HA!



  • Lolz!

    Of course it's not a list to a list... guess that's what happens when you've not had the appropriate amount of tea/coffee in the morning and the words go down on the page incorrectly.

    Or was it a massive trap for you? 😂

  • @DibB  we found another quirk with cloudworks and it has been raised with anaplan . 


    Use case :- we had a test model where we were testing cloudworks integartions . We then arhcived the model however cloud works were still running in the backgroud for some reasons . Cloudworks tried looking for the model and consumed all the memory which brought down the entire workspace down . users were unable to log in 


    So we had to disable cloud works integrations for that model manually . 


    Hope this helps someone 

  • DibB

    @karanAMP Thanks for letting us know. Can you please create a support ticket? We'll look into it as soon as possible.