PlanIQ [internal server error] Meaning




while making the data collection for PlanIQ, I faced with "internal server error" and failed data collection.

By adjusting the original module (by putting time dimensions for row), the issue is now solved, but I'm now confused about the term "internal server error" since the term seems to be broader than "your module view setting is wrong".

What triggers the "internal server error"? and what does it means? (or, trying to indicate?)


Thank you

Best Answer

  • Ingilavicus

    Hi @KimJeongjun ,


    Can't give you answers, but I faced a similar issue. Seems to be a generic message to indicate that something went wrong. 

    In my case, I was able to run the data collection step but was failing to train a model. In my case, it turned out to be an issue with the source data as I used 3 hierarchies in rows, while it only supported 2 at the time. 

    I worked with Anaplan support to pinpoint the issue, so presume if anyone has this error the support team is able to pinpoint the exact problem, just takes some time.  


    If anyone ever has odd issues I would recommend following the setup guide extremely accurately:

    For me, that did the trick. 






  • Thank you! I found another case in the community that had "internal server error" and it was also due to the setting the module in a wrong way for planIQ, so I guess the message is quite generic as you said.

    thank you for the link, I was able to train different model following the setup guideline in the link! hope you have a nice day/night.