How to import a csv file into a module where the only reference is a single line item (text format)



Any idea how to import this csv file:


into this module:

The third column (PR Number) is in text format (8 characters truncated from the first column) and its not a list nor a parent/child of the first column (PR line).

Parent of the first column (PR line) is something else i.e Material. 




I have nothing  from Source to match with PR (Target)





Best Answer

  • KirillKuznetsov

    LOOKUP works properly with list-formatted line items. Please add line item "PR ITEM" format - list, 'PR2' .
    Insert formula FINDITEM('PR2', PR Number). Make sure that PR Number is text-formatted. Then make your {property_in_source_module}[LOOKUP:PR ITEM]. If it does not work - please send the error message


  • @LimPhingHuayou have to create PR number list and a module dimentioned by the same. then add all necessary fields which you want to import. then you will have to create two imports. first will load new PR numbers. second will load all the rest to this new module using PR number as a key. after that you can link (via lookup) your module to the transactional module to get the data in the target.

  • I did that earlier.  Created a flat list of PR Number  and another new module with PR Number as dimensions and line items for the data input. But had trouble with getting the LOOKUP formula right to get the data into the target module  (Dimension issues). The new module created with the new list after import as below:


    I couldnt get the data into the target module below with Lookup formula.

     PR No in new module (above) is list and PR Number in target module (below)s a text property

    (truncated 8char from PR Line eg 12176647-10-00).




  • New module dimensions: PR2 and line items:

    Note: PR2 is the list generated from PR numbers earlier. 

    csv. file data import into this module with no problem.


    Target module has dimensions PR and line items as below

    (Third column in this module although named as 'PR Number' is actually text ...not from list )

    I tried LOOKUP...tried SELECT and have no idea how to make it work





  • Its working!

    Thank you