Level 1 Certification: Activity 4 and 5


Hi, I am been working diligently all day on a single problem and am coming up empty. The problem never occurred during the training and need some advice. Basically, when I import the "SYS08+Employee+Details" txt file into sys08 file unfortunately even though I map correcty the Role dimension, which I formatted as a list, Role, comes in blank. Never during training did i see this issue. I have the lookup formulas right, using the Sys08 module as bridge between "EMP02 Employee Expenses" and "EMP03 Employee Drivers by Role" modules. 


Please help, been dealing with this since 9am today.



  • @briiseliyou have to check multiple things here:

    1)"Role dimension, which I formatted as a list," sounds confusing since a dimention is the list anyways. Are you sure you not talking about a line item formatted as list?

    2) Do you have elements in Role list? - they won't get generated automatically if you load into a module.

    3) Is this Role list numbered? - if yes - make sure you have code so elements of the list could get mapped.

    4) Try to copy and paste the role name to one of the cells and see if it fits there. Sometimes this can help.

    Could you send screenshots of your source module blueprint and import settings?

  • Here is the screen shot of all my modules, emp02 and emp03 and sys08 and the screenshots of how I imported everything and the formulas using lookup I use and showing role as zero.

  • @briiseli 


    On the import, do not use Fixed Item, but rather the code.

  • I tried that but it is still not coming in in full

  • the reason is that the code is coming in as "1" instead of "001" so not mapping to file. is there a fix or do I have to manually map each of these codes to the 3 digit format?

  • I tried converting the text file to excel as well but that didnt help. Manually I can grow through and build an automation formula in excel to convert single digit numbers to 3 digit numbers by adding 2 zeros in front and 2 digit numbers to 3 digit numbers by adding 1 zero in front before importing, but am hoping there is a simple Anaplan fix?


    there was no mention of this during training.

  • I redownloaded the .txt file and it gave me right 3 digit code so all set now and got full code map matching for file. Not sure why it worked, but after trial and error it works. Thank you for your help.