PlanIQ - failure to add Attributes in Forecast Model

Hi Community, 

 

When in PlanIQ I run a Data Collection that contains historical data and attributes, the Data Collection fails. I receive an error message saying that attributes don't include all items in historical data (screenshot attached), which is not true, because I use exactly the same list of items in both historicals and attributes. What could be the reason for that issue?

Comments

  • @MaciejD 

     

    Are all the attributes text formatted?

     

    Also 0's in historical data - you may want to remove outliers if they are not actual zeros

  • Hi @Misbah ,

     

    Yes, all attributes are text-formatted. 

    The zeroes in historical data are true zeroes, indicating that zero items was sold on a given day .

     

    Thanks,

    Maciej

  • @MaciejD 

     

    And in your export action have you enabled "Row label headers"?

  • @Misbah 

    Yes, I did. I use code as an identifier (same as in the export of historical data).

  • @MaciejD

     

    Could you please share the Data Collection Window for Historical data as well as Attributes data?

     

    Hope export is in .csv format

    Hope there is nothing in related data.

  • @Misbah

     

     Attached are screenshots of Properties of the Data Collection. Is that what you ask for?

    There is no Related Data in this collection.

  • @MaciejD 

    As far as I know there should be start date & end date ranges here

     

    Misbah_0-1631535934483.png

     

     

  • @Misbah 

     

    Well, when I include historical data only, a Data Collection is succesful, and the time/date range is there. 

    But when I include also Attributes, data collection fails and there is no time/date range information.

     

    Regards, 

    Maciej

  • @MaciejD 

     

    I think that is the problem. Your timescale is not identified by PLANIQ.

     

    Also make sure that the number of line items in Attributes module do not go more than 10

     

    Misbah

  • @Misbah 

    My timescale of historical data is correctly identified when no attributes are included in the data collection... The problem occurs when Attributes are added (and the attributes do not have timescale, so i don't see where my timescale is incorrrect).

    What an akward issue. Thank you for your help anyway.

  • @MaciejD 

     

    Yes, with the limited amount of resources and training materials available I feel you may have to recreate the Data collection once again.

     

    We know where the error is , it's just that we don't know where to look for in order to rectify it. I would highly recommend keeping the attributes <=5, although it can go up to 10. 

     

    Hope that helps

    Misbah

  • Hi @MaciejD ,

     

    I took a look through everything you've posted and don't have an immediate solution at the top of my head.

     

    Have you submitted a support request via clicking the "..." next to the data collection and clicking "Email Support"?

     

    Tim

  • Hi @timothybrennan , 

     

    Thank you for your response. Yes, I submitted a support request a few days ago, but the problem was not resolved, so I still seek for help. 

     

    Do you have any examples or experience with any set of attributes that were succesfully added to data collection? Maybe such a blueprint could serve as an inspiration. I made numerous attempts to set up the attributes, but it always ends with a collection failure. 

     

    Kind Regards, 

    Maciej

  • Hi, 

    I'm getting the same error message, but both lists are the exact same. Would also like to know what could cause this.

    Thanks!

  • I messed around with my data collection, and I finally made it work. 

    The change that made this error go away was adding a letter to the codes of my Item Unique Identifier list, which only contained numbers previously. For example, I changed my codes from being 6010125204 to A6010125204.

    Is it possible that the error came from the fact that PlanIQ would read my item ID as 6.01E+09 instead of 6010125204 because of the .csv export? Adding a letter forced the .csv file to display the whole string. 

    @timothybrennan  Let me know what you think.