Update Current Period Action from Data Hub Not Working


I’m having trouble with Updating the Current Period action using an imported line item from the Data Hub.


I created a systems module and added a Current Period, time formatted line item with no dimensions in the Data Hub and Spoke Model. I created the action to Update the Current Period in the Data Hub and it worked without errors. However, I cannot import the Data Hub line item into the Spoke model. The mappings do not work. I receive an error message that “Current Period” (which is the name of my line item) isn’t recognized in the calendar. If I add a dimension to the modules, the import works but the line item isn’t recognized in the Update Current Period action. Any suggestions please? Thanks!


Best Answer

  • saglago
    Answer ✓

    Hello @JessicaD 


    According an article written by JaredDolich importing data into a dimensionless model is fine for a Data Hub, but model to model imports is very challenging without at least one dimension. 


    Create a flat list called “Administration” and add one list item called “Value”. Use this as dimension in your Data Hub module. This will help and allow you to map/ import the current period into the bespoke model.


    Let me know if this helps.




  • @saglago 


    Thank you - this worked! I was able to create the flat list and apply as a dimension in the Data Hub. In my spoke model, I set up a module with a Current Period, time formatted line item but no other dimensions. I was able to import from the Data Hub. The Update Current Period action recognized the line item since no other dimensions were applied.


    I really appreciate your help!


  • I was having the same issue. Thanks for outlining the solution! @saglago 

  • @JessicaD - When I run my Update Current Period Process in my spoke model it takes a minute or two to run. The process is only doing two things (1) updating one line item in a system module from my Data Hub and (2) updating the Current Period. I'm guessing the process time is because of the update to Current Period in Time. Do you experiencing a similar process time? 

  • @saglago I was having the same issue and wondering if there would be a hack for that! Thank you so much!