Mapping Issues due to dates




I'm currently having mapping issues with the current Flat File I'm trying to load into Anaplan. It is saying it can not match up the dates, but I'm hoping I will not have to manually change the dates on my flat file verses getting a way for Anaplan to read the dates to map the data. Please advise. 






Thank you 

Best Answer

  • JaredDolich


    Gotcha! Let's take this step by step. You will continue to get the error because Anaplan doesn't know what to do with the 2nd column "order". Since your line items are in column 1 and your lists (time) is in the column headers, you've exhausted all the mapping options. I can only think of two ways you can get the magical green checkbox. First, You'll have to remove the order column from your source file since it doesn't seem to be needed. Second, create a list called "order" with one list item in it called "1" and change your source file to be "1" for all rows.  


    This will not work:


    This will work Option 1:



    This will work Option 2:





  • @neg177 

    You should be able to use Y-M-D "periods", or try using a custom fixed-position pattern YYYY-MM-DD

    Make sure you match the date format of the SOURCE not the TARGET.

  • still getting same error when I customize the date setting. 



  • My apologies, I was trying to map to the Target and not the Source like you said. Now I just get this failed error...



  • @neg177 

    Your source data is Y-M-D

    Try that combination or use the custom build code with YYYY-MM-DD or YYYY?MM?DD

  • I believe I have my time set correctly now, but I still get the following error below. The data is still getting loaded into the Module, but I need no errors at all because we are trying to create a OneCloud connection and we need to make sure our mappings have no errors for this. 


     Thank you 

  • @neg177 

    Almost there. Almost there. Can you please show me the time format you are using? Should be Date, Y-M-D, or Custom build, like YYYY?MM?DD. 

    See? Your source is YMD



  • Yes Almost there lol, thank you so much for your patience. I have used both the Y-M-D and YYYY?MM?DD and still getting the same error with both. Its just that error saying "Expected 2 or 4 digit year in date/period". 



  • Thank you so much for your help. Your awesomely awesome!