Data Import Increasing Value


i'm having an issue importing data into our data hub module. i did not change any of the field characteristics, it has a minimum significant digits of 4 and is in number format. 


The problem comes that when importing the CSV file, there are 0's being added to the end of the number that increases the numbers value. 


You can see in the examples that the ProdAmount is supposed to be 12, but then when imported it becomes 1,200. And again 726,375.47 becomes 72,637,547. This happens for every number in the import. I've tried updating the data type in our CSV to general and number format, and updating the anaplan number format to no avail. 


Does anyone know the cause of this issue and how to fix it?





Best Answer

  • KirillKuznetsov


    You have to check import data source settings for this import. Probably in discimal separator is set to comma or somthing.

    Also i would check which column do you use as unique key for your import. This may be the case that you uploading the same number x100 times because you are missing some unique identifier.

    Hope it helps.



  • @kmillet 

    Check how you have defined the decimal separator and thousand separator in the import.

    If your source data has changed how these are defined you will need to make sure that you can use a more consistent source. 

  • Thanks! the issue was the comma/decimal separator in the import. 


    appreciate the help!

  • Enis
    I experienced the same problem and I solved it thanks to your advice. Thank you.