Level 1 Model Building Exam Activity 4 - Roles Import Error

Hi there,


I've been stuck on the import into the SYS08 Employee Details Module (Activity 4). When I run the import, I get the error below:


I think this is what's preventing me from sourcing the right answer for Question 5, since the mapping on activity 5 works well for me. 


Here's how I set up the Roles list:




I've added "Role" as a List line item on the module, and the information populates only partially. After the import, I see data only for "staff members" .


Where did I go wrong here?


Thanks in advance!


Best Answer

  • @AJakote 


    Why is the line item Role a subsidiary view, meaning it has different dimensionality than the rest of the module?  It shouldn't be.  Please to back to that line item (Role) and make it have the same dimensionality as the rest of the line items (Applies To should have a -)




  • Hi @AJakote 

    What is the source of your load and can you send a snip of the import mapping for role line item 


  • Hi there,


    I hope I understood correctly the "source of load" as the source file of import for Activity 4 - which is this text file: 


    When I'm running the import, this is my mapping:



    Another weird thing is that the "Leave Date" formatting is blank when I set the format:



    As to the role, it's mapped in the following way on the SYS08 module:



  • I didn't even observe this was missing - the import worked like a charm now! Inserting a snipped of the solution down here: