Abnormal behaviour of Actions


Hi Anaplanners !


Is Anaplan facing issues in the Action Mappings?


I had renamed few line items(eg: Line Item A renamed to Line Item B) in the model, and tried to test the actions, but none of them worked. When i checked the mapping of the actions, what i saw is really strange. I saw two line items (Line Item A and Line Item B) both present in the mapping table. And mapping was still intact with Line Item A and Line item B was ignored. 

But as per my understanding there should be only one line item i.e. Line Item B.


I saw this in more than 5 actions where i renamed the Line items in the specific modules.





Best Answer

  • alexpavel

    @anand.shekhawat Indeed this is an old annoying issue that is still there... 😞


    Renaming a line-item works very well, except if the line-item is used as "source" in a saved view which is used in an import action. If the mapping in the import action is made "manually" the source line-item remains mapped with the old name and the new line-item is shown, but it is not mapped. 

    The import runs with a "successful" status without updating the target line-item. 


    So, when renaming a line-item you should always check if that line-item is part as "source" in an import action. (manual check). 


    The renaming of a line-item is not an issue if it is used as "target"..in that case the import action is correctly updated using the new line-item name. 


    check this idea exchange:



    There is an old reported issue that was reported to be solved, but it is not solved 😞


    Issue 74688 - "When importing data between modules where a line item in the source module was renamed, data matching was based on the name of the old line item"


    Hope it helps



  • @anand.shekhawat 

    To my understanding anaplan works this way with import manual mappings always. It works as a snapshot of some kind and remembers all manual selections for mapping.

    That's why if you rename a list which is used as a dimension for any source module - you will have to go and change settings in the applied actions.


  • @KirillKuznetsov But my point is when Line Item is renamed from 'Line Item A' to 'Line Item B' . Then 'Line Item A' should not even exist in the mapping table, coz it's been renamed in the module. Why is it still there ? So to understand refer below


    Initial mapping

    'Line Item A' ----------> 'Salary Numbers'


    After renaming 'Line Item A' to 'Line Item B' the mapping showed in the mapping table as

    'Line Item A' ----------> 'Salary Numbers'

    'Line Item B' ----------> ignored


    But ideally after renaming it should be

    'Line Item B' ----------> 'Salary Numbers'


    I hope i am able to make you understand the scenario.




  • @anand.shekhawat 

    I understand your concern.

    But manual mapping cannot be automatically reassigned and i think it is the feature specific for list items.

    Let's assume you have a logic when list items being filtered dynamically in your source module. And for some reason the list item got renamed. This way you would like to keep the manual mapping fixed and not interrupted by any changes.

    With the line items as they are more like a structural elements I argee that it may be weird that they are strictly mapped. But again it depends on a case.

    Manual mapping is always "a hardcode". So if you decide to apply it - be ready that you will have to fix it later if something changes in structure.

  • @anand.shekhawat 


    Yes, even I noticed it a few days ago that it doesn't replace the line items, instead it remembers and keeps both the line items. Manual Intervention is required to map the action again and Ignored the outdated line.


    Not sure if this is the expected behaviour.



    Miz Logix

  • @alexpavel 

    It really helps and thank you for the same. I never thought this would be a long time running bug at Anaplan's end. I hope it gets sorted at the earliest. Else it might cause data issues in the production which might go unnoticed.


    Thank You @Misbah and @KirillKuznetsov for your inputs.




  • @Misbah 


    It shouldn't be "expected" behavior.  My guess is it is cached, but @anand.shekhawat should put in a case/ticket to support so it can be looked into further.



  • @rob_marshall 


    I'll raise it with Anaplan, Thanks Rob