Transactional APIs > "Retrieve dimensions IDs for a line item" not working




Can anyone provide the request code for Retrieve dimensions IDs for a line item? I tried to create & test the below code but its not working


curl -X GET '{modelId}/modules/{moduleId}/lineItems/{lineItems}/dimensions' \
-H 'Authorization: AnaplanAuthToken {anaplan_auth_token}' \
-H 'Accept: application/json'



Best Answer

  • M.Kierepka
    Answer ✓
    Try this one: /models/{modelId}/lineItems/{lineItemID}/dimensions
    So without specifying exact module. It works for me.


  • Yea, it worked for me a well. Thanks

    One quick question - why doesn't it works with models/{modelId}/modules/{moduleId}/lineItems/{lineItems}/dimensions but works with /models/{modelId}/lineItems/{lineItemID}/dimensions
  • I think the "extended" path shouldn't be in the documentation, as it looks like someone proposed this, but it was not implemented due to the fact that it would be just a duplicate endpoint.
    But you need to ask Anaplan Support for exact explanation, and let them know that this endpoint is documented, but doesn't work - so either they need to implement (but why duplicate behaviour that is already implemented using the shorter path...) or remove from the docs.