Drill-down for second chart - page sync and chart filters not working together


Hi everyone,


I'm finding that when I enable a filter on a dashboard chart in the UX, then page sync is not allowed for that chart.  I want to be able drill down into the chart figures - this drill down doesn't appear possible yet in the same chart (Drill down for a chart - Anaplan Community), but it should at least be possible using a second or further charts using sync right?


Basic example:

I have a column chart, chartA, in the dashboard UX with one particular KPI, sales for this month, and each column is a region.  I want to build a duplicate of this, chartB, that is synced to chartA, so that if I click on region1 column in chartA, then chartB will display the sales for the countries within region1.


I want to use filters but when I enter a filter on chartB, the context selector to allow syncing with the page (including chartA) is greyed out so isn’t allowed



  • Just countries, so without the underlying customers (these would be on a third chart, as too much information otherwise) – the hierarchy is region / country / customer;


  • Filter out countries with zero sales for a start;
  • Later if possible - top 10 countries within region1 - my rank filter works but only when not synced with the rest of the page - I have removed these two filters for now as I want to get the show/hide feature syncing first;




  • Hi @ddevine ,


    By any chance are you using Select Levels to Show within your Chart B view? Hierarchy filters do not work when using Select Levels as well.


    Our "Active SIN" is the bottom level of the hierarchy and rolls up to our P2. The view we are using to display the Active SIN grid is attached. I included how it displays on the New UX both with and without Select Levels to Show active. As you can see, the ability to toggle the Hierarchy Filter for Active SIN is greyed out when we have Select Levels active, but once it is removed we are then able to toggle the filter on and then add page selectors/syncing ability. 


    Hope that helps!



  • Hi Timmy,

    Thanks for your reply, no i'm not using "Select Levels" in the underlying module nor the module that module is drawing from.

    I see that when I select a filter or a show/hide option within the dashboard that the context selector gets greyed out.

  • Hi @ddevine ,


    Got it, perhaps try removing the filter and publishing the chart, then after it is published go in to your saved view and add the filter and re-save it, and then see if that works for you? I believe we've done this trick when we're using Select Levels to Show before and it has worked for us.


    Hope that helps!

  • Hi Timmy


    I prefer creating the view within the UX itself, as a saved module view might get deleted.  I tried what you said though but it didn't work.  Thanks for the suggestion



  • Hi @ddevine ,


    Sorry that didn't work for you... hopefully someone else can come up with a better solution! Thanks for trying anyways.


    Good luck,