reset times for minor issues are becoming a major pain i Anaplan


13 minutes because i used number instead of text as a format !!

Surely this can be prevented, it makes developing a very slow process and stops a very busy office from working.

Are we supposed to develop out of hours????






Best Answer

  • GeorgeDuckett
    Answer ✓

    @DeveloperCYT I have created a browser extension that solves a lot of this, providing live syntax and semantic checking. It doesn't handle absolutely every cause of errors, but it does handle the common ones (such as your example), and missing LOOKUPs etc. It also has pretty clever code completion, particularly with helping suggest LOOKUPs/SUMs needed (intelligently picking the correct lookup lineitems). I've got a post about it here.


  • Hi @DeveloperCYT 

    There is no way to **** the processing time in Anaplan yet.


    In bigger Modules, where the number of integrations to other modules are many, the processing time would be higher in that error. so, it is better to be more cautious in bigger modules. nevertheless, its always good to check in line items before coding even for smaller modules. 

     another way to improve this is by improving the model by keeping check on optimization(sparsity, daisy chains, summaries, lists dimensions for constants, versions).


  • @ManjunathKN 


    Actually, it doesn't matter the size of the module, it has everything to do with how the model has been architected.  When there is a rollback, the model essentially closes, opens back up, and replays all changes up until the misstep.



  • Hi Rob,


    I can understand and focusing before pressing the green tick helps, but sometimes it just happens

    Surely a "system based" syntax check before submitting a formula would stop this from having to roll back for the simple errors

    More complex formula being wrong, I can understand and have to live with those


    It doesn't happen so often any more but when the supply chain are shut down for 10 - 20 minutes they can get a bit frustrated.

  • @DeveloperCYT 


    Oh, I agree with you, my post was not responding to you, but to @ManjunathKN .



  • Badam

    @DeveloperCYT ,


    You are right, In a few cases of syntax error or format type mismatch at a source and target level also have this challenge. I think this is related to the Anaplan formula checking architecture.


    I have seen a few products, who does the syntax level check and format check before applying it to the complete model. This reduces the overall error time. 


    @rob_marshall , please check if it can be taken as a part of the product roadmap or enhancements


  • Thanks, i have installed the add-in but as far as i can see it does nothing for me.

    I am writing and editing formula and :-

    ctrl shift and space changes the module from blueprint view to line item view

    ctrl space brings a box up that says 'no suggestions'

    alt shift f does nothing
    Maybe i am missing something, but the add-in is present and working, so not sure what i am missing?




  • @DeveloperCYT Have you refreshed the page since installing the addin (sounds like maybe not)? Which browser are you using? Are you using the new modelling experience?

  • Hi,

    I have refreshed the page, restarted the laptop, i am using miscrosoft edge and yes the new user experience.

    Its a puzzler



  • @DeveloperCYT Hmm. Just tried on my machine getting the addin from the edge store and it worked fine.

    Does the 'F' icon appear like this top right when on an anaplan page:



    If you press F12 to bring up the console are there any red error messages (don't worry about any yellow ones, those would be from the normal anaplan site)?

    If, with the F12 console showing you get to a page with url like (the url you get when you open a module) then press refresh (F5) do you get a message similar to this:



  • yes i have the Blue F icon, and i have tried in Chrome and Edge



    Amber and Blue, but no red

    if i press F5 in a  module i get


    went into another module and that one has a red error



  • Hmm, I'd have hoped to see the "Set anaplan from"... in the console. If that's not there, then the extension hasn't loaded / integrated with the default editor properly, and so won't have any of the enhancements.

    If you click on the F icon do you get a similar view to what I showed (showing the editor has access to the site)?

    Can you please click 'top' on the console then show me what appears:


    I'm hoping "Better Formula Editor for Anaplan" appears several times like it does here.



  • This is the top of the screen


    and top of the cosole view




  • @DeveloperCYT Ok, given the "top" info I can see it's normal that you don't see a "set anaplan from" in the console message like I do. I get that because I'm in the EU, but on a US server, so the lack of that message for you don't mean that's an issue. Given this, though, I'm not sure where the issue lies at all. The fact that it doesn't work on each browser you've tried says to me it's not like you've got some other extension that's interfering or anything. You said auto-complete doesn't work, but does hovering over a line item? 



  • Looking at this red error that looks like I'm not handling the 'SELECT' on a time period correctly. I'll look into this separately. For now when testing the extension please use a module that doesn't produce this error.

  • Hello George,

    Well, here is a turn up, it has just started working on both Chrome and Edge.

    Very strange, as i didn't restart again, just closed and opened the browser a few times.

    So, thanks for your guidance, and confirming that i am not going insane

    I am really looking forward to using this extension, it looks amazing

    thank you once again


  • that SELECT is in old test module, and bad bad coding. it's gone now
  • That is odd. There's not really anything I can think of that would cause a delay in it starting to work. Oh well, glad it's sorted now at least. Please let me know how you get on (I'm always keen to hear about usage / suggested enhancements etc).
  • No problem. I should still probably handle it without producing an error though.
  • do you think net nanny or kid safe software would stop it working?
  • That is possible, although I'd have thought a bit unlikely.