Import data into DAT03 "Expected week number in date/period"


Hi Anaplan fam!
Since I have read almost every post about importing into DAT03 and checked the instructions many times, it seems I have exhausted all possible options.
The only way I can import from Datahub is by using Match names in the Time tab. When I add line item "Offset Volumes for 1st Forecast Year", the value is always zero.
In screenshots, you can see how I broke down the formula. In DAT03, the "1st Forecast Year?" checkbox should be checked. Additionally, I have included a screenshot from SYS01 in which "1st Forecast Year?" is checked. I checked both models' time settings and versions and everything else I could think of that could cause this issue, but I couldn't resolve it.
I would appreciate it if you could share some ideas about what might be wrong?


  • Hi @mattb 


    Your import worked correctly, the data is loaded.
    You need to "move" the loaded data one year ahead by using the formula OFFSET through the first year check.
    You will end up with a formula "IF 'SYS01 Time Settings By Week'.'1st Forecast Year?' THEN OFFSET(Volumes, -52, 0) ELSE 0" that will move the data forward.

    Снимок экрана 2022-06-05 в 12.01.41.png

  • @AntonMineev thanks for your time and reply.

    Here are some tips for future learners... Having struggled for days with this challenge, I checked everything in the process, from the Datahub to the actions and processes in the supply chain model. It is subtle, but when you create the Time range of FY19, it has only one period in it by default. Attached is a screenshot for your information. You need to change the number of periods from 1 to 2. 

    Screenshot 2022-06-06 084455.png