Set one column of source data as "Not Applicable" for this import


Dear Anaplan Community 


I am looking for a way to "ignore" one column of data from the source file as irrelevant when uploading its data into module.

Source file contains columns as below. Column D is actually the code of Column C inside Anaplan model. And Column D is there because client wants visibility into expense type 2 codes as well while budgeting.

Screenshot 2022-08-04 at 12.56.49 AM.png My target module has Plan Week, Team, Expense Type 2 and Time as dimensions. My current upload action mapping is like below. The numbers will still get uploaded correctly just that Anaplan will throw error message saying that the Code Column is invalid time identifier which is confusing for end users in terms of user experiences. Is there a work-around on such situation without changing my source file format and avoid the error message?


Screenshot 2022-08-04 at 1.03.01 AM.png

Appreciate any thoughts on this.




  • @tingtingxia 

    This is a limitation of Anaplan. When importing data Anaplan must have the answer to two questions:

    • Where can I find the values for the lists in this module?
    • Where can I find the line items?

    Since time is being used as a column, you'll be forced to fix the line item to one value unless the line items are all organized in a single column. The extra column you have is an property that belongs in a system module not within the transaction module.

    Only suggestion I have is to see if it's possible to remove the column to avoid the errors. You can still use this file as-is but you'll get errors on the time dimension.

  • @tingtingxia 

    We had a similar issue what you have mentioned here and we have created a workaround in Anaplan to ensure that we do not have the error message.

    I have tried taking the sample of the data screenshot which you have shared.

    Basically, in your case you just 1 line item not being mapped. So, we will create a line item in the target module with a subsidiary view. If we have 2 line items to be mapped, then we need 2 line items and each line item should have some different dimension. Attached screenshot from the target module.

    Since we have #30 has another dimension and a subsidiary view which is an input, during the import it will ask you to map it with some column and we will map it will the line item which will throw us error.

    Vola!! The process will run successfully :)