Importing Data into a list from module returns blanks


I tried to import data into a numbered list from a module and except for the parent and code columns in the list all the other data updated with blanks. I have attached the screenshot of the mapping used during import. 

Best Answer

  • kevinsanghoi

    I tried it that way. It didn't work so I added formulae to the properties of list that were not being loaded during import and got it running.  


  • @kevinsanghoi Check your formats of target and source if they match together.

  • @kevinsanghoi 

    You're on the right track! Best practices suggest that we should avoid adding list properties and rather create a system module that uses that list and add line items for each property. So for example, here is the SYS08 employees module that is numbered. IMport your properties to this module instead.





  • They do match

  • Thanks Jared.
    The model I am working on is an existing model and this is something that I can't update right now. I am able to fetch the department code as well in the above mentioned mapping but the columns such as job code, job title return blanks

    Kevin Sanghoi
  • @kevinsanghoi 

    That's an unfortunate circumstance. There are a couple of possibilities here why the data is not loading.

    • The parent doesn't exist
    • The code in your file doesn't match the code in the list

    What does the error log reveal? It will tell you why the data isn't loading.

  • The parents exists as well as the code in the module(source) matches the code in the list(target).   

    As you can see in the screenshot below I have few columns populated and few of them are blanks.




    There is no error message during the import.


    Kevin Sanghoi

  • @kevinsanghoi 

    Awesome. Then the solution should be easy. We just need to see where Anaplan is getting confused. Let's go back to @bhatjaved idea. 

    • Is the code and the title formatted as text or as a list? If it's a list then you need to make sure those list items exist. To be certain, can you share the list blueprint (properties) so we can look together?

    For the three records you shared what is in the import file? Is the code and title there?

    Trust me, this is an easy win. We just need to see where the disconnect is.

    Later, when you reach the finish line, we'll talk about moving all these properties to a system module where they belong. hehe....


    All the properties in the list have the format set as text. 

    For the 3 list items that I have shared the code and the parent as present in the import module as line items. 


    I too feel this is something relatively easy but I am missing a small detail somewhere




  • @kevinsanghoi 

    Try clearing the import action (delete it) so the source/default file is removed. You might be loading an old file. Then try reloading the data from scratch, remap as usual.

  • I have tried deleting the action. I even did the import directly from list options rather than running the existing action but nothing seems to work.

  • @kevinsanghoi 

    Try manually changing the code and title for 2 or 3 records. Make sure there are no special characters.

  • Sure, will try that.


    Thanks Jared