cloudworks process runs but no data transfers


I am using Cloudworks for the first time purely for scheduling transfer of data.
I have a process that simply imports data from a module to a list within the same Model.

I set the Cloudworks process up and it successfully runs (green tick)
However it does not actually import any data.
If I run the process (action) directly in the model it works, and imports the data

Why would the Cloudworks process run but not actually import the data?

Best Answer


  • @andrewtye - the selective access one is tricky and got us too on the initial setup.
  • @Tiffany.Rice half the problem (much like with that area) is it's hard to find the Internal User. But we get there!

  • DeveloperCYT_0-1662017330684.png

    My list has now got Selective Access and Internal(Full Access) as suggested but alas the Cloudworks runs, the process and action runs, but still no data is imported.

  • Did you set the Internal(Full Access) assignment in the Target list?

  • Finally solved it

    The Module that the data is exporting from has a list, that has a parent that is Selective Access, so i updated the parent list to have Internal(Full Access) and voila the data from the module has imported.
    Thanks for the help, go there in the end.

    Note: Make sure all module source lists, whether they are source, parent or grand parents that have selective access, are set to Internal(Full Access).


  • Excellent! It's quite the tricksy thing... SA is great except for this!

  • Hi,

    I have another import and that model does not have Internal(full access) in the user list when I try to add read permissions? How does that user get set-up ?