3.4.3 Activity: Create Country Summary Module: Country Made In not populating


I am running into an issue where I either get no population of Country Made In, or I get an error.


It accepts this




But does not populate this




And does not accept this, which is apparently the correct way to do it:




Also worth noting here is it will not allow me to select "Distribution Center?" when trying to create the formula, despite the data clearly being there:




Even weirder is, that's the list, right? SYS06 has the same data. So I tried:
PARENT('SYS06 Location Details'.Distribution Center?) but got this:



 So it won't let me use the list because the formula is invalid, but it won't let me use the module, because it has to be a list?
I tried using this instead, because both the G3 Location List and the SYS06 Location details have common dimensions, like "Code" however 
'SYS06 Location Details'.Country[lookup: Supplied By], and
'SYS07 Distribution Center Details'.Country[lookup: Supplied By]
result in:



And this is true for any column.


  • @jadefortunato 

    You're doing everything right, you just need to remove the subsidiary view. In the "Applies To" column make sure you have a dash "-" or explicitly match the module lists "P3 SKU". You can see the line items with subsidiary views by looking for the little grid icon next to the line item. In your case, there's one next to the "country made in" line item.



  • Thank you, I've been losing my mind... however... there is no option to reset that field. The reason it's blank and not a dash is because I was messing with it earlier and had it set to P3 SKU, then decided that wasn't the way to go, and found there was no way to get a blank, so I highlighted and deleted it, but that apparent didn't do it either... how do I reset that field? Essentially it's a dropdown with no blank option that once you select one, you must select one.

  • @jadefortunato 

    You can copy the dash from the line item above, enter a dash, or use the P3 SKU list. All should do the trick! You got this!

  • I ended up recreating the line, however, weird quirk: leaving blueprint view afterward would not show grid view, it just showed a blank grid. I had to reload the model.



    Thank you for this I was at wits end.