Import Action not found in the Workspace and Model


Hi Team , 


Using Anaplan Connect , I'm trying to bulk import from database to Anaplan.

I have created a script to import data into Anaplan and also JDBC Properties file.


I'm getting an error like Action "Import Action Name" is not found in the workspace "XXXXX ID" and Model "XXXX ID"


But when I check the import action list using REST API. I could able to find the Import Action in the list.

I dont understand , whether it is going wrong. 


Can you guys help me out to solve this issue ?






Thanks in advance 🙂 



Vinoth Kumar K.


Best Answer

  • pyrypeura
    Answer ✓

    Now checking that in the script it says "'Import_Test1.csv'" not found. So it seems to have extra '-characters in the name that it tries to find. Could you check on how you you have inputted the name of the import action to the script? Validating the action name and getting rid of extra '-characters hopefully will solve the problem.


    Best regards,



  • Hi,


    It seems that in script you have "Import_Test.csv" and the correct name of the action is "Import_Test1.csv" . Correcting the name of the action in the script should fix this issue.


    Best regards,

    Pyry Peura

  • Hi Pyry Peura , 

    Thanks for the reply.

    Even I tried with Import_Test1.csv , it is showing same error.




    Vinoth Kumar K.