Import clearing data that's not in the saved view


Hi all,

I'm stuck in an weird import action. My goal is to clear data in few line items via an import. My module has 2 dimensions (one is native time and the other one is sales reps). 

This is a screenshot of my module view.



This is the saved view I used for import.


First I created clearing line times with No Data format (as in the screenshot above). In my import setting, I use the default option (Clear target prior to import) and selected Mapped items in each dimension mapping. Once I ran it, it actually clear all three months of all these 3 reps, which is not what I wanted. I can't fix this. It doesn't work as expected. What I want is to clear Jan for rep 1, Feb for rep 2, and March for rep 3.


Second, I changed the clearing line item formats to the same format as their target line item (e.g., changed Clear Item 1 to number and Clear Item 2 to List (product category). Then I changed the import setting to Only update imported cells. This time, it is only updating the 3 records in the saved view, but it didn't clear line items other than the number-formatted one. I tried using Blank as formula in other line items, but still didn't work.


In all examples I've seen on community, the import works fine when there is only native time dimension. Can someone share their solutions to clear item when there are two dimensions (native time and one custom list)?


Thank you!