Filter on Line items based on Lineitems subset is not working in NUX



I have a Module INPUT with 2 line items and and a List Cashflow categories as dimesion.

Now I want these lines published on a view on a board and Cashflow categories as page selection.

Based on the cashflow categories I want these lines items filter i.e, for some categories it should show 2 line items, for some categories 1 line item and others it should not display line item.

So I create a another SYSTEM Module with Line Item Subset on the INPUT Module and Cashflow catergories List and a Filter boolean line item and made the necessary checks.

This filter when applied on the backed is working absolutely fine But it does not work on the NUX.

In NUX it does not even ask for the Line item to be filter on

Normally it should ask for the line item to be filtered on right?

Is it a bug or am I missing something here?

Thank you



  • Hi @CommunityMember131103

    This definitely seems like a bug. Meanwhile the bug is resolved you can try two things.

    1) Try to pivot line items on columns instead of rows.

    2) Publish a Saved view instead of using custom view on NUX



  • That's how it should work - we do exactly the same thing for some of models where certain areas don't need to input for certain metrics.

    Might just want to check that the filter works as expected within NMX - might be that the LISS isn't quite right. Worth ticking all the boxes then you know it's working correctly.

  • @andrewtye and @megha09 Thanks for your response.

    @megha09 Even that was my Idea to use saved use and its working fine but problem is with conditional formatting I want to use more than 3 colours. But thank you again.

    But today I tried to apply the filter again its working fine.

    Bit strange though.

  • @CommunityMember131103

    Anaplan sure works in mysterious ways sometimes, cause the day I was trying to do this on my account it showed me the same warning on filter but when I asked my colleague he was able to apply the filter and we both have same accesses, so yes it sure is strange. Anyways its good to know its working now at least for you. Still doesn't works for me though :-(