Import script as stopped working, but the manual import runs succesfully


I am importing data from Snowflake and successfully saving the csv file, this has worked for about 2 years

They changed their column headers, I then downloaded the new format csv, and created a new import using this file, which works 100%

However, when i add the new import to the script it crashes at the import stage

Transferred 1689 records to storeStock.csv

Running Process: updateStoreStock

Run Status: Failed.

Property-based import has one of the key properties unmapped - cannot proceed

There are 3 fields in the import and all of them are mapped, so I am confused, did i not map the new file correctly, should it be set to Admin, Private or Everyone, or am I missing something else?



  • @DeveloperCYT

    A couple of thoughts and questions:

    • When you uploaded the new file, what was the permissions on it? You would put this as Everyone.
    • When you uploaded the new file, were you logged in using your ID or the Integration user ID? Is there an integrations user ID?
  • Hi,

    I set it to everyone (i actually tried all 3 just in case)

    There is not an integrations user ID, and I have 5 other scripts that work using this method, but the Skutrak(Snowflake) changed a file structure and now I cant get it to work using the script, but I can manually download from Skutrak and manually import the same file ok.

    So I am guessing it's a small thing I have missed

  • @DeveloperCYT

    Interesting...Have you tried to using the "sledgehammer" approach and deleting the action and recreating it with the new columns?

  • I will give it a go, and build from scratch.... back soon

  • Sherrieward
    edited March 2023

    If your script for importing data has stopped working, but manual import is successful, it may be due to an issue with the script itself. You can try debugging the script by checking for any errors or inconsistencies in the code.

    Some possible reasons for the script not working could be:

    Incorrect syntax or formatting in the script

    Changes to the data source or format that the script is not handling correctly

    Permissions or access issues with the data source

    To troubleshoot the issue, you can try the following steps:

    Check the script for any errors or syntax issues that could be causing it to fail.

    Make sure that the data source is accessible and that the script has the necessary permissions to access it.

    Verify that the data format or structure has not changed and that the script is still able to handle it correctly.

    Test the script with a small sample of data to see if it is working as expected.

    Consider using a different import method or tool if the script continues to fail. SkyWard Alpine