L2 Sprint 2 Import data DATA02 shipping metrics


Import Ignored most likely due to different dimensions. However I don't see anything in original excercise saying dimension should be weekly in the data hub module, please assist ?

DATA HUB it is Model calendar year

>> Time scale Year

In Supply chain this is based on time range.

>> Time scale Week

Supply Chain Module


  • AjayM

    Hi @akrem ,

    Please set target module's time scale to YEAR (not WEEK). You can't import data from YEAR scale to WEEK scale. The action result might say ‘success’ considering the dimension mapping, but the columns got ignored as WEEK doesn't match with YEAR.


  • akrem


    I adjusted this in supply chain import worked. Is there any reason it was set to week instead of year in supply chain module ? There was no mention of adjusting this in tutorial for level 2.

    » Changed to year then import worked

    This is import result.

  • AjayM
    edited March 2023

    As we proceed with exercises and levels of model building, not everything is explicitly detailed all the way, and we are expected to apply logical thinking, as we are getting used to the use case, purpose of each activity and the model building itself.

    Whenever we create a new module with time dimension, it gets created with lowest time level (based on our model's time settings). And hence, by default, the module got created at week level in supply chain model.

    Also, though it looks like it worked, I see another issue in your time setting of DAT02 in Supply Chain model. You have set it to time range FY19-20, while the shipping metrics data (DAT02) in data hub is for FY20 and FY21 years. This means you would be able to import data only for FY20, the common year between hub and supply chain model currently.
    Please change your DAT02 time setting in supply chain model to model calendar, which gives you the correct years (FY20 and FY21), for successful complete import at this step.