Anaplan-Power Bi Connection using Basic auth-Blank source

edited March 2023 in Modeling


I am trying to connect Anaplan & Power bi, I followed steps metioned on Anaplan community, but I was not able to see data in Power Bi.

In Anaplan I have created one test export action.

In Power bi I have entered below url

in next step, I'm using my Anaplan User name & Password associated with the models.

but I'm not seeing any data source

Which step I'm missing ?

Best Answer

  • AlejandroGomez
    edited March 2023 Answer ✓

    Are you in the “visting” list or in the “internal” list of the tenant users?


    I have been running some testing with my own account and some of my colleages.

    Once you create the connection from PowerBI to Anaplan, it seems you can only see the Models from the Workspaces within the Tenant where you are an Internal user (as opposed to Visiting)

    For more details, I have access to certain Tenants throguh SSO and to others throug the BASIC connection.

    In Tenants accessible through SSO I am “Visiting”, so I could not see anything at all, same as you:

    Accessing through BASIC, I have acces to multiple Tenatns and Workspaces from different clients, but I can only be “Internal” in one Tenant at a Time. And that Tenant's models are the only one available in PowerBI.

    This hypothesis has been tested with colleages who are “Internal” users in other tenants different than mine and seems to be true.

    So, if you are in the “Internal” list of a Tenant you should see in the Navigation page of PowerBI the models from the workspaces within that Tenant. You do not need “Integration” or “Tenant Admin” roles for this.


  • AlejandroGomez
    edited March 2023

    Hi @swapnil_J

    it seems to me that you are mixing up the basic and the SSO authentications.

    on this pic, you are using the Auth for SSO users:

    as per extracted from the documentation:

    Basic authentication

    If you choose Basic authentication, enter the following URLs: 

    Anaplan API URL

    Anaplan Auth URL 

    SSO authentication

    If you use SSO authentication, enter the following URLs: 

    Anaplan API URL

    Anaplan Auth URL 

    whereas in the next step, when entering your credentials you are using the “Basic” option instead of the “Organsiational Account” one, which is the one meant to be used wiht SSO:

    I hope this solves your issue.



  • Hi Alex, I have tried with above urls as well but still I'm not seeing any workspace/models/exports.

    Do I need to clear any cache or change anything in browser setting?

  • I dont think so,

    I have tried myself and, despite not finding any documentation about it yet, i believe your issue is caused by your permissions within your Anaplan tenant.

    When I created a new connection to PowerBI myself, I can only see the data sources from the Anaplan Workspace and Tenant where I am “Integration Admin”.

    You, or your Tenant Admin, can check this in “Administration”


    And then look for your account and permissions within your Anaplan tenant

    Once you are granted the right permissions there, You should see the available models within your workspace in PowerBI

  • Thanks for the inputs Alex.

    I have page builder and WS Admin access but not integration Admin or Tenant Admin may be that not having these two access are causing this issue. If possible can you please try by removing this two access?

  • Thanks a ton Alex!

    I am part of visiting list, and may be that is the issue.

    Thanks for the detail soultion.

  • Happy to help!