Issue in ALM Sync Up across Tenant


Hi Everyone,

We have moved one workspace from one tenant to a new tenant in which the prod model was there.

After its migration, I took a copy of the prod model and make a dev model from it and make a mock deployment but the ALM was not intact between them.

Then I tried one more approach where I made a new model from Create model from the Revision Tag option, that option worked and made the ALM Intact but that new model needs to be ready again as all the lists need to be rebuilt again, and all the subset and mapping needs to be defined again.

Is there any way to resolve this issue?



  • Instead of copy model (i believe it breaks the alm as it creates a new revision), you can import the model you need.

    Importing doesnt break alm sync.

  • @david.savarin - I imported the Prod Model into the Dev Workspace and then changed the mode of the imported model from deployed to standard. Now I tried to do a deployment between the dev and prod model but it failed.

    It gives the following error.

    Is there any way to avoid this kind of error and make sure my ALM is intact between the dev and the prod models?

  • THen i d suspect that your alm sync in prod is broken.

    Maybe obvious : after importing : Did you add some changes and a rev tag on this newly dev model ? Sync will fail if no newer rev tag exist in your source model.

    I had a similar issue with a model and it appeared after investigation that the deployed model had been modified outside of synchronization through alm.

  • Hi @PulkitChawla21

    The method mentioned by @david.savarin should work. I too have created new DEV models from PROD models using the method in past and it works.

    I used to follow these steps:- Import model from another workspace > Change mode of imported model to Standard > Do dev work in imported model > create revision tag > sync/compare to the original model

    The error is coming up because the copy model (standard mode, DEV) may not have newer revision tags and when there are no new revision tags, Anaplan can't find something to compare it with.