Facing Issues with Anaplan REST APIs


Trying to export a module via REST APIs, but neither able to hit modules API to list all the modules nor the exports API. The user is workspace admin and still giving "Not Found" error.


  • Hi @meghababbar ,

    Can you share the URL's by removing the Sensitive information please?
    So that we can help you with the earliest.


  • Venki9902
    edited June 2023

    Hi @meghababbar,

    I have tried the below URL's and got the success status:

    To retrieve workspace details:

    To retrieve module details:https://api.anaplan.com/2/0/workspaces/{{workspaceId}}/models/{{modelId}}/modules

    Hope this helps :).


  • Hi @Venki9902

    Retrieving model and workspace details is working fine for me. But somehow it's not working beyond that level, failing for modules, exports, files, lists etc.

    Please suggest some ways to debug this issue.

  • Hi @meghabbar,

    https://us1a.app.anaplan.com/2/0/workspaces/<Workspace ID>/models/<Model ID>/modules

    Then when you'll find your modules with this url you can change 'us1a.app' part from url with 'api' and recheck. This way you can find if problem is in your url or somewhere else.

  • Hi @meghababbar ,

    Can you highlight on the variables to see if you have values or not?

    And your token value you are applying the latest one I believe and in the header’s section try adding content-type once.

    hope this way it will helps.



  • @meghababbar These symptoms suggest that the account you are using to run the commands either does not have permission to access the model or that one of the IDs is incorrect (workspace ID or model ID).

    Some things to check:

    • Ensure the account you using in Postman is the one you are intending to use
    • Ensure the workspace and model IDs are correct
    • Check the workspace level account settings within Anaplan:
      • Ensure the account is set as a workspace admin for the workspace
      • Try disabling SSO for the account within the workspace you are accessing
    • Check the model level account settings within Anaplan:
      • The account must have a role set within the model (i.e. cannot be set to No Access)
    • Ensure you are able to access the model through the UI when logging in with the same account (and ensure you log in to this account without SSO)