Level 2 - 1.3.6

Options
DanielR
edited July 2023 in Academy Discussions

Hello Community,

I am working on lesson 1.3.6 in Level 2. Currently trying to import location details. Although there are no error messages, instead of getting the data arranged orderly by 6 columns (as in the data file), it all comes as one single stack as in the snippet below. Does anyone have an idea how to resolve this?

Many thanks, Daniel

Best Answer

  • anand.shekhawat
    Options

    @DanielR

    It seems that you have loaded the Region Flat list incorrectly.

    It should be in the below format

    After this correction try reloading the file. This would help your Region Line Item to populate

    For location do not worry too much if it is not getting imported. Try writing a formula - ITEM(Location Flat)

    And it will populate the Location details.

    ~Anand

    https://in.linkedin.com/in/anand-shekhawat-35645486

Answers

  • Try to pivot the dimensions and then import.

    Thanks,

    Bishal

  • Hi @DanielR

    So i hope you have imported the data in blueprint view. Please have a look on import lessons.

    If the issues continues please drop a message. I will happy to help you.

    Thanks

    Deepak

  • DanielR
    Options

    Thank you!! Will try it out

  • DanielR
    Options

    Bishal, Deepak, Community,

    I've tried importing data for the SYS07 Location Details module, this time doing it from blueprint and pivoting line item in columns and location flat in rows (like Bishal instructed in the response) but still getting the result in the snip below. Any ideas how to overcome this?

  • Hi @DanielR ,

    You should not do on blueprint view. Instead you have to use plain view.

    If issues continue, please free to drop a message. I will be happy to help you.

    Thanks

    Deepak

  • DanielR
    Options

    Thanks @Deepak5805 !

    Sorry but it's really not working. I tried again from the plan view and this time the import is not even going thru:

    Would sincerely appreciate any additional as I do want to understand the story here.

    I have important many data items successfully in Level 1 but this one is just not going.

    Many thanks, Daniel

  • Hi @DanielR

    It sounds that you are having a real trouble in loading the data. Don't worry we would sort this out.

    First of all please make sure that your 'Location Flat' list is populated. If not then Anaplan would throw error while loading the Location details, as those locations are not even present in the first place.

    Now, it comes to load the location attributes in the SYS07 Module.

    I could see that you have created the required 'Line Items' in the module. Now, kindly follow the below steps

    1. Navigate to the default view of the module and NOT the blueprint view
    2. Click on Import under 'Data' and chose the correct file which contains the attributes or the location details.
    3. Make sure you do your mapping correctly
    4. Kindly Map the location details with the respective codes and go through all the tabs. Make sure everything is mapped correctly
    5. Now run the import

    It should definitely populate your SYS07 Module.

    Please let me know if it helps

    ~Anand

    https://in.linkedin.com/in/anand-shekhawat-35645486

  • DanielR
    Options

    Thanks @Anand.sekhawat!

    I double check that the locations flat list looks good. Seems like there is some progress but it is still out of whack, Thoughts?

  • @DanielR Thanks for sharing the file.

    To make you understand better. Kindly follow the below steps

    1. Make sure you pivot the module in the below format.

    2) You would get a view something like below

    3) Make sure that you have created the line items which are asked in the training module. I have just replicated the view that you have posted in the question.

    4) Now lets import the file, below is the mapping that i have done while loading the data.

    5) Make sure that you all the other tabs are mapped correctly. For eg all your locations should be mapped as below. Just scroll till the bottom and check

    All your line items should be mapped as shown below. If it is not getting mapping automatically, then please map it manually by selecting the boolean to map manually

    6) Now run the import. You will get the data imported as shown below

    Make sure you have formatted the line items as asked in the training module.

    I hope it should work for you know.

    Please let me know in case you still face any trouble in importing the files.

    ~Anand

    https://in.linkedin.com/in/anand-shekhawat-35645486

  • DanielR
    Options

    Thanks @anand.shekhawat! I went through all the steps over the weekend and indeed made progress. However, the final result is still a bit off. Would you know what is missing?

  • @DanielR So your 3 line items are getting loaded successfully but 2 of them(Location & Region) are still causing trouble.

    Could you please post the screenshot of your module's blueprint view?

    Also please verify if you have loaded data into 'Region Flat' List?

    ~Anand

    https://in.linkedin.com/in/anand-shekhawat-35645486

  • DanielR
    Options

    Hi @anand.shekhawat,

    1.Confirming that I loaded the Region Flat list:

    2.Here is the blueprint view of SYS07 Location Details:

  • DanielR
    Options

    @anand.shekhawat Thank you! I was able to fix the region flat list per your feedback and will work in the next few days to correct the dependent items. Thanks!