Anaplan export action list via POSTMAN

Hi All,

I have this issue on not being able to get the list of Anaplan export actions or any other artifacts via POSTMAN.

These are the steps I am taking -

a. Authenticate — (I using basic auth and I am able to authenticate, and I am able to get the tokenValue.

b. Model list - I use the token value (BEARER TOKEN) from step a and I am able to get the model list using.

c. List of export action or any other artifacts. After the second step, when I try to get the list of export actions, or processes or lists, this is where I am not able to get those lists.

Since I got the tokenValue in step a, I should be able to use the same method as in step b.

I tried both of these lines (one with workspaces and one only with models in the GET command

Any other options I can use?



  • Hi @khoonks,

    Are you using the official Anaplan collection? If not, try and see if it still doesn't work:

    Also, what error message/code do you get in the response to your requests? Are you sure that you have access to the target model? I agree that if step B works for you, you are properly authenticated and other requests should also work normally.

    FYI, both endpoints (with and without workspace) should work, so without more info I am not able to identify the issue.

  • Hi @khoonks,

    I assume you are using example workspace id's and model id's, right? Those in you post do not even get close to real id's. So please make sure you use a valid id. You can get it from the URL of you anaplan workspace.



  • @StevenBeerthuizen - I would not want to add my official Workspace id and model id here.

    @M.Kierepka - Thanks for the official Anaplan-Postman URL. Let me try that, and I will keep you posted. By the way, i have always been able to get it working by working the CA CERT auth. This is the first time I was trying the BASIC auth. Thanks.