The Action is not working in new UX, but works fine in Classic Dashboard

edited July 2023 in User Experience

The Action has two unmapped dimensions that the user has to select, but as shown in the screenshot 'Capture1 .Png', It will consider only one dimension for both the selections in NUX, hence the dimension does not get mapped resulting in error shown in screenshot 'Error 1.png'.

But in the Classic Dashboard it shows both the Dimension selection as shown in 'Capture 2.png' and the data import runs successfully.

I have recreated the action, recreated the page, recreated the action button, still this issue persists.

I am currently working in "" platform. Please let me know if there is a quick solution to it.

Best Regards,

Supriya R M



  • anirudh

    Hi Supriya,

    I could not replicate this myself. I created an action with 2 custom mappings and it works fine in NUX

    The issue with your import could be that you are mapping the time dimension and it's leading to some kind of error. Can you share a screenshot of the import action's edit view and the dimensions of the module where you are loading the data

  • supriya
    edited July 2023

    Hi @anirudh

    It is not a mapping issue, because if it was the mapping issue, then the actions should not have worked successfully in Classic Dashboard resulting in the same error as in NUX. Please note that the import action is working fine in Backend and in Classic Dashboard. But it is not working in NUX.

    Thanks, Supriya

  • anirudh

    Yes I understand. What I was trying to say was that the mapping issue is not an issue with the action but rather that Anaplan is probably having trouble parsing the time mapping on NUX.

  • There is a difference as you are seeing with an Action run from the dashboard verses from the UX Page. I do not know the answer to that question.

    But this error is usually that the list import item is not within the target list. If P1 is a custom list, the Action will successfully run from the UX Page; however, it will still have the map dimension labels that are not correct.

    My example is using this dimensioned target module:

    Along with this Process Mapping:

    A way to avoid this is to use Line Item list Selectors, one for Period and one for Year along with a non-dimensioned line item import for each to a staging module prior to going to the final transactional module. BUT rather than do that, one of the CoE's recommendations is to use the Model Calendar. Ideally try to obtain that data from the User upload (YYYMMDD). It will save both Users and Builders' time.

    The presented example will run into many challenges: (1) Users' have no safeguards in what they load. (2) Periods (P1-P12) do not have a natural year association. (3) Builder will need special mapping module(s) and will loose function options.

    If something like this must be done, limit where it is done, like as an input or on an output display. If it is an input, immediately convert to Anaplan native time. If it is an output grid, the mapping from Model Calendar to P1-P12 can be done there.

    I am making some assumptions based on what you posted. Hopefully some of this applies and will help you with the issue.