Error when importing into module with numbered list as dimension


Hi Anaplan Community,

I try to import data from a saved view in my source module to my target module.

My target module has numbered list #L3 SKU-Plant as its sole dimension.

My source module has the material list as sole dimension. As part of my saved view in source module, I created a line item "L3 SKU-Plant list item 1st Manuf. Site" which has the format of #L3 SKU-Plant, with formula FINDITEM('#L3 - SKU_Plant Master', 'Generated SKU-Plant based on 1st Manuf. Site')

When I use that line item as the mapping key between my source and my target module, Anaplan throws me an error: "Ensure the column headers in the import file map to the correct dimensions in your module, then run the import again".

When I use another line item, which is text formatted with formula NAME('L3 SKU-Plant list item 1st Manuf. Site') (i.e. taking the name of the list-formatted item, in this case the hashtag code of the numbered list), and I use that as mapping key, then the import does work.

Can anyone explain? Why would the import not work if I use the list item as mapping key?

see screenshots attached


  • @LouiseBourgonjon

    Yes, because on a numbered list and using a list formatted line item, the member could be in several places within the hierarchy. For example, if the Display Name is list formatted, how would it know which member to update?

    Additionally, I would not use the #ID, use the code.

  • Hi @rob_marshall ,

    Thank you for your quick reply.

    I would think Anaplan stores both the hashtag code (unique identifier) and display name when using a list-formatted line item, but apparently it doesn't.

    I used the code instead of the #ID and it also worked.

    One more question: although I only have 5 items in my saved view, in the mapping tab of the L3 SKU-Plant list, Anaplan tells me it can not preload the mapping (Manual mapping is unavailable when number of items exceeds 5000). See screenshots attached.

    How is that possible?

  • @LouiseBourgonjon

    No, it does not store both the Display Name and the #ID, just the #ID. And for your 2nd question, while your view may only have 5 members in it, how many members does the list actually have?

  • rob_marshall
    edited October 2023


    And on the last part, is your source of the import a view or just the module?

  • My source of the import is a saved view, filtered on these 5 items.

    The list in itself does indeed have much more members, but then again, I would expect to only see the 5 members selected in the saved view.

  • @LouiseBourgonjon

    Because it is reading the entire list.

  • There seems to be something strange, now it is no longer working, neither using the CODE, neither using the NAME for mapping… Strange because this afternoon it worked. Now I again get the error message "Import into DAT1_SKU_Plant Master Data module unsuccessful: The dimensions in the target module do not match the import definition."

    I really don't understand

  • @LouiseBourgonjon

    When importing into a numbered list, you should only use code. Do you have the code in the target module as well? Can you show us the mappings?

  • I did not change anything overnight, ran the import action again this morning and now it works again. There seems to be inconsistent behavior in Anaplan, I will need to report this as a bug.

    I only use the code for mapping. See mapping import definition attached. I import code of L3 SKU-Plant master data item into target module with list L3 SKU-Plant master data.

  • I decided to remove my import action & import data source and recreate it. Upon creation it did work, I will now monitor if it continues to work.