Data loss issue


I've encountered a strange issue in our model.

To give you the context - We run a scheduled process through REST API to copy data from one version to another version. We tried running this using cloudworks, it did not work (I'm assuming because once of the action in the process has filter based on User Write Access). So we decided to run process using the API.

The process was running fine and we had no issue. Yesterday when the process ran, it copied data from original version to another version and then cleared all the data from original version. I do not have any action that clears the original data in the process.

When I tried looking into the history I found something strange. User had made the value change from False to True. However When the process ran, The History log shows that the previous value was False and New value as False as well. Attaching a screenshot for reference.

Then we ran the process again, everything works fine now, None of the above mentioned issue came up. Raised a ticket to Anaplan Support as well.

Why did the History log miss capturing the information when the True value was changed to False?

Has anyone came across a similar kind of issue ? Or am I missing something?