Anaplan error: Line item not recognized


Dear Community,

I encountered an issue during the build of some of our projects and would appreciate further clarification if possible.

Brief description of the case:

I have two modules, A and B, that contain the same line item names "Adjustment" (module1.Adjustment, module2.Adjustment). When I tried using the same formula in both modules (copy - paste taking into account the module dimensions), I encountered an error stating that the line item wasn't recognized.

The error log:


IF '
      SYS19 - Versions x Time'.DCA Write AND Adjustment = 0 OR NOT 'SYS19 - Versions x Time'.DCA Write
      Net Sales Calculated
      Net Sales Calculated + Adjustmen

PS: Rewriting the formula would resolve the issue, but I'm seeking clarification regarding the copy-paste method, which we have used in the past without encountering any problems related to item recognition.

Thank you & Best regards,

Best Answer

  • RdEl00
    Answer ✓

    @rob_marshall Thank you for your answer. I literally copied the module with the same line items just to be sure of the LI names. I tried the exercise once again, and apparently the issue was solved. Maybe it was a temporary technical problem.


  • can you explain what "copy - paste taking into account the module dimensions" is and how it differs from just copying and pasting between line items?

  • RdEl00

    @MarkWarren, thank you for the prompt reply ☺️. It's the same thing, I just want to emphasize that even if the copy-paste action was done between two modules with different dimensions, I still took into consideration to adjust my formula so any syntax error won't be flagged. However, the non-recognition error for the line item (Adjustment, in our example, the one with a common name between the source and target module) remains existent.

  • rob_marshall
    edited February 5


    Are you sure there isn't an extra space before or after "Adjustment"?